Results 1 to 2 of 2

Thread: /usr/bin/spamc not found?

  1. #1
    Join Date
    Jun 2016
    Posts
    1

    /usr/bin/spamc not found?

    Hi,

    I installed Spamassassin, Easy spam fighter and blockcracking using the custombuild DA gui. I had it rewrite the exim config. I also have the spamassassin , ESF and BC config in place.


    A lot of mail errors out;

    2016-06-14 16:48:54 1bCo6z-0002DP-Ai <xxxxxxx>: spamcheck transport output: An error was detected while processing a file of BSMTP input.
    2016-06-14 16:48:54 1bCo6z-0002DP-Ai == xxxxxxxxx R=spamcheck_director T=spamcheck defer (-24): Transport filter process failed (127): unable to execute command

    I figured /usr/bin/spamc is not present on my server.
    Here is the relevant part of the config that custombuild created
    Code:
    #COMMENT#54:
    spamcheck:
      driver = pipe
      batch_max = 100
      command = /usr/sbin/exim -oMr spam-scanned -bS
      current_directory = "/tmp"
      group = mail
      home_directory = "/tmp"
      log_output
      message_prefix =
      message_suffix =
      return_fail_output
      no_return_path_add
      transport_filter = /usr/bin/spamc -u ${lookup{$domain}lsearch*{/etc/virtual/domainowners}{$value}}
      use_bsmtp
      user = mail
    I installed mlocate to try and find spamc. Its nowhere to be found.

    What am I doing wrong?

  2. #2
    Join Date
    Apr 2005
    Location
    GMT +7.00
    Posts
    13,475
    Hello,

    I'd suppose that installation of Spamassassin failed due to missing required perl modules.

    Check this guide: http://help.directadmin.com/item.php?id=36 and install all the requirements.
    Regards, Alex G.

    - Get the best commercial DirectAdmin support and hire me on poralix.com
    - Follow and like @Poralix on Facebook

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •