Results 1 to 6 of 6

Thread: Spamassassin tries to connect to ipv6

  1. #1
    Join Date
    Aug 2009
    Posts
    33

    Spamassassin tries to connect to ipv6

    I get lots of messages like these in my logs (mail.err):

    Code:
    Jun 29 08:43:31 server spamc[22603]: connect to spamd on ::1 failed, retrying (#1 of 3): Connection refused
    Spamassassin seems to work normally, but I wondering why I get these messages. Especially because Spamd is started with ipv4 option:

    Code:
    ps aux|grep spamd
    root     21079  0.0  0.5 180152 81816 ?        Ss   06:25   0:01 /usr/bin/spamd --pidfile /var/run/spamd.pid -d -c -m 15 --ipv4
    root     21080  0.0  0.5 194012 96500 ?        S    06:25   0:06 spamd child
    root     21081  0.0  0.4 180152 77420 ?        S    06:25   0:00 spamd child

  2. #2
    Join Date
    Jul 2008
    Location
    Maastricht
    Posts
    3,716
    Use this to limit to ipv4:
    Code:
    /usr/bin/spamd -d -c -4 -m 15
    The -4 takes care of the ipv4 limitation.
    Greetings, Richard.

  3. #3
    Join Date
    Aug 2009
    Posts
    33
    Thank you for the reply.

    I thought the --ipv4 would take care of that. I will try what happens when I change the spamassassin service.

    Edit: spamd is running now with the options you provided. Still getting these error messages.

    Code:
    ps aux|grep -in spamd
    247:root      3972  0.3  0.5 180000 81652 ?        Ss   09:14   0:01 /usr/bin/spamd --pidfile /var/run/spamd.pid -d -c -4 -m 15
    248:root      3973  0.2  0.5 185908 88220 ?        S    09:14   0:00 spamd child
    249:root      3974  0.0  0.4 180000 77316 ?        S    09:14   0:00 spamd child
    Last edited by rvandam; 06-30-2017 at 12:19 AM.

  4. #4
    Join Date
    Jul 2008
    Location
    Maastricht
    Posts
    3,716
    Oh you are using another OS or using spamd another way. On my system with Centos 6 it does not have a pid file and is started via Exim, looks like this:
    Code:
    ps aux|grep -in spamd
    174:root       898  0.0  0.0 105432   928 pts/1    S+   16:36   0:00 grep -in spamd
    244:root     17092  0.0  0.1 247928 61760 ?        SNs  03:46   0:08 /usr/bin/spamd -d -c -4 -m 15
    245:root     17094  0.0  0.2 263112 77524 ?        SN   03:46   0:06 spamd child
    246:root     17095  0.0  0.1 247928 59868 ?        SN   03:46   0:00 spamd child
    However if I look at other processes, the command line comes before the pid line, like this:
    Code:
    mail     17086  0.0  0.0  64992  1652 ?        SNs  03:46   0:00 /usr/sbin/exim -bd -q15m -oP /var/run/exim.pid
    Maybe your's should be changed to:
    Code:
    /usr/bin/spamd -d -c -4 -m 15 --pidfile /var/run/spamd.pid
    for it to work correctly.
    Greetings, Richard.

  5. #5
    Join Date
    Aug 2009
    Posts
    33
    Thank you for your reply, I really appreciate your help.

    I am using Debian8 with a default Directadmin custombuild install. Strange that there are differences between our systems. I played a bit with the options, but nothing resulting in stopping the error messages. Spamassassin scans incoming mail so that part is working, but for every incoming mail it generates an ipv6 error message in mail.err.

    I found a solution here and this seems to work well. In /etc/mail/spamassassin I added the file spamc.conf, containing this line:

    Code:
    -d 127.0.0.1

  6. #6
    Join Date
    Jul 2008
    Location
    Maastricht
    Posts
    3,716
    Thank you and you're welcome, I like to try and help, only pity I did not find a solution. Luckily you did.

    A bit odd that it's working different in Debian indeed. One would expect that at least the commandline options work the same way since the documentation does not say anything different.

    Great you found the solution, I'm sure others will be helped with this one too if they read it!
    Greetings, Richard.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •