Results 1 to 17 of 17

Thread: Apache stopped

  1. #1
    Join Date
    Mar 2018
    Posts
    1

    Apache stopped

    Hi,
    I just upgraded the apache to 2.4.33. But Apache has stopped.

    Mar 25 10:36:36 ****** systemd[1]: Starting The Apache HTTP Server...
    Mar 25 10:36:36 ****** httpd[23326]: AH00526: Syntax error on line 18 of /etc/httpd/conf/extra/httpd-hostname.conf:
    Mar 25 10:36:36 ****** httpd[23326]: SuexecUserGroup cannot occur within directory context
    Mar 25 10:36:36 ****** systemd[1]: httpd.service: main process exited, code=exited, status=1/FAILURE
    Mar 25 10:36:36 ****** kill[23328]: kill: cannot find process ""
    Mar 25 10:36:36 ****** systemd[1]: httpd.service: control process exited, code=exited status=1
    Mar 25 10:36:36 ****** systemd[1]: Failed to start The Apache HTTP Server.
    Mar 25 10:36:36 ****** systemd[1]: Unit httpd.service entered failed state.
    Mar 25 10:36:36 ****** systemd[1]: httpd.service failed.

  2. #2
    Join Date
    Mar 2018
    Posts
    4
    Hi,

    I've the same error after update in custombuild.
    Change webserver nginx_apache to apache don't change anything.

    I d'on't see where the error is. My line 18 : SuexecUserGroup webapps webapps

  3. #3
    Join Date
    Jul 2011
    Posts
    167
    The same problem here! (Debian 7, 64bit)
    End Times - Now! video (turn on English/French subtitles)

  4. #4
    Join Date
    Mar 2018
    Posts
    4
    I've tested to downgrade the apache version and it works.

    HTML Code:
    cd /usr/local/directadmin/custombuild
    echo "apache2.4:2.4.29:" > custom_versions.txt
    ./build update_data
    ./build apache

  5. #5
    Join Date
    Jul 2011
    Posts
    167
    An another temporary fix seems to be to change the php type from fastcgi to php-fpm in DA options.conf and and then execute ./build update && ./build update_versions
    Last edited by jet1972; 03-25-2018 at 04:03 AM.
    End Times - Now! video (turn on English/French subtitles)

  6. #6
    Join Date
    Aug 2006
    Location
    LT, EU
    Posts
    8,142
    We are very sorry for the appearance of this bug. It has been fixed in CustomBuild 2.0 rev. 1848. A quick-fix would be:
    Code:
    cd /usr/local/directadmin/custombuild
    wget -O build http://custombuild.eu/build
    ./build apache

    Thank you!
    Martynas Bendorius
    MB Martynas IT. Professional server management company. Official DirectAdmin, CloudLinux, LiteSpeed and Comodo partners.

  7. #7
    Join Date
    Sep 2015
    Posts
    71
    I know this is an old thread but I have the same problem after update right now

  8. #8
    Join Date
    Aug 2006
    Location
    LT, EU
    Posts
    8,142
    Quote Originally Posted by psalm91 View Post
    I know this is an old thread but I have the same problem after update right now
    Could it be changed PHP settings without rebuild of PHP?
    Martynas Bendorius
    MB Martynas IT. Professional server management company. Official DirectAdmin, CloudLinux, LiteSpeed and Comodo partners.

  9. #9
    Join Date
    Jun 2019
    Posts
    82
    Quote Originally Posted by psalm91 View Post
    I know this is an old thread but I have the same problem after update right now
    do you use comodo mod security ? if yes try to change it to owasp
    Trying my best

  10. #10
    Join Date
    Sep 2015
    Posts
    71
    Quote Originally Posted by DanielP View Post
    do you use comodo mod security ? if yes try to change it to owasp
    No I don't

  11. #11
    Join Date
    Sep 2015
    Posts
    71
    Quote Originally Posted by smtalk View Post
    Could it be changed PHP settings without rebuild of PHP?
    Can you please explain a little more

  12. #12
    Join Date
    Jun 2019
    Posts
    82
    Quote Originally Posted by psalm91 View Post
    No I don't
    can you post the exact error

    systemctl status -l httpd
    Trying my best

  13. #13
    Join Date
    Sep 2015
    Posts
    71
    Quote Originally Posted by DanielP View Post
    can you post the exact error

    systemctl status -l httpd
    https://pastebin.com/raw/FAd3E9p6

    I see some thing in there about mod security but I do not see modsecurity I my admin interface no where!

  14. #14
    Join Date
    May 2014
    Location
    Netherlands Germany
    Posts
    562
    Sorry double post error
    Last edited by ikkeben; 08-03-2019 at 01:01 PM.
    DUTCH GERMAN, GERMAN DUTCH

  15. #15
    Join Date
    May 2014
    Location
    Netherlands Germany
    Posts
    562
    Quote Originally Posted by DanielP View Post
    do you use comodo mod security ? if yes try to change it to owasp
    Quote Originally Posted by psalm91 View Post
    No I don't
    uh it looks like you do see error yourself.

    pd-modsecurity.conf: Syntax error on line 1 of /etc/modsecurity.d/comodo_rules.c onf.main: Could not open configuration file /etc/cwaf/cwaf.conf: No such file or
    DUTCH GERMAN, GERMAN DUTCH

  16. #16
    Join Date
    Sep 2015
    Posts
    71
    Quote Originally Posted by ikkeben View Post
    uh it looks like you do see error yourself.
    thanks but how to resolve? For some reasons mod security is not in my directadmin interface and no folder

  17. #17
    Join Date
    Jun 2019
    Posts
    82
    If you use Graphical Custombuild2 in Admin Interface Extras plugin > Edit Options tab> Web ...

    mod.png

    edit the options and to owasp save and build the rules (Build ModSecurity Rules ) and rewrite_confs at Build Tab


    better way for me and for you if you are ok with shell

    go to
    Code:
     cd /usr/local/directadmin/custombuild
    folder

    edit at options.conf

    modsecurity=yes
    modsecurity_ruleset=owasp

    ./build modsecurity_rules

    ./build rewrite_confs


    or set modsecurity to no and rewrite confs I do not know what is the end goal
    Last edited by DanielP; 08-03-2019 at 05:30 PM.
    Trying my best

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •