Results 1 to 18 of 18

Thread: DirectAdmin 1.54.0 has been released

  1. #1

    DirectAdmin 1.54.0 has been released

    Hello,

    We're very pleased to announce the release of DirectAdmin 1.54.0.
    This release has many new features and bug fixes.

    All changes listed here:
    https://www.directadmin.com/versions...rsion=1.540000

    New Features:


    Bug Fixes:


    Update:
    As usual, to update DirectAdmin, go to:
    Code:
    Admin Level -> Licenses/Updates -> Update DirectAdmin
    or with the Evolution skin:
    Code:
    Support & Help -> Licenses/Updates -> Update DirectAdmin
    Evolution Skin:
    We're pleased to finally include the new Evolution into the update.tar.gz pack.
    Please note that the skin is now in RC1 phase of testing, and although it should be fine to use, there could still be bugs, although we're not aware of any.
    If you do find any Evolution bugs, please report them to the forum:
    https://forum.directadmin.com/forumdisplay.php?f=96

    John
    Last edited by smtalk; 09-15-2018 at 03:25 AM.

  2. #2
    Join Date
    Apr 2009
    Posts
    2,186
    Regarding this feature: https://www.directadmin.com/features.php?id=2175 and regarding the option "letsencrypt_account_email=" you mention in reply #14 https://forum.directadmin.com/showth...919#post290919 and your reply #9 in https://forum.directadmin.com/showthread.php?t=56852

    We now have a situation where the new DirectAdmin version was released without any information and answers as to what have been done or not? We need answers on these:

    1: Does letsencrypt.sh 1.1.11 include support for letsencrypt_account_email= option?

    2: The email field is now removed from the SSL page https://www.directadmin.com/features.php?id=2175 - is it now needed to do a conversions for existing certificates?

  3. #3
    Join Date
    Apr 2005
    Location
    GMT +7.00
    Posts
    12,494
    @ditto,

    I see a new default letsencrypt_account_email=0

    Code:
    # /usr/local/directadmin/directadmin c | grep letsencrypt_account_email=
    letsencrypt_account_email=0
    with DirectAdmin v.1.54.0

    and

    Code:
    # grep letsencrypt_account_email /usr/local/directadmin/scripts/letsencrypt.sh -c
    0
    with letsencrypt VERSION=1.1.11

  4. #4
    Join Date
    Apr 2009
    Posts
    2,186
    @zEitEr, Thank you. But it is kind of confusing, because letsencrypt.sh 1.1.11 was released long before reply #9 at https://forum.directadmin.com/showthread.php?t=56852

    But I would be happy to not use that option. However I would need DirectAdmin support to answer what the consequences is? What happens with existing lets encrypt certificates, would they continue to renew with the users email address? If not, is it needed to do any conversion for existing certificates? Would it be possible to let them automatically be converted whenever they was up for renewal? (that for be the best)

  5. #5
    Join Date
    Sep 2015
    Location
    Arnhem, NL
    Posts
    406
    https://forum.directadmin.com/showth...919#post290919

    I've added:
    letsencrypt_account_email=0

    to the internal DA setting for now, and we'll update the letsencrypt.sh later.
    It does nothing in the DA binaries, just stores the setting.
    Great to see that the new skin is making progress and is nearing the final release .
    Last edited by Erulezz; 09-15-2018 at 03:52 AM.

  6. #6
    Join Date
    Apr 2009
    Posts
    2,186
    @Erulezz, But we still need information now _before_ we upgrade DirectAdmin. We need to know what happens to existing certificates, and we need to know if it is needed to do a conversion, or if they are converted to admin email automatically when they are renewed next time?

  7. #7
    Join Date
    Nov 2016
    Posts
    23
    Nice work on the skin!

    To enable it i go to reseller level -> skin manager. Why issn't there an skin manager on admin level?
    I would like to enable the skin server wide. there for i push "Set Global". But afther that. I go to admin level -> list of resellers -> just an reseller -> login. But then the old skin loads. How to fix?

    Jordi

  8. #8
    Join Date
    Jul 2008
    Location
    Maastricht
    Posts
    3,548
    Just to be sure:
    Code:
    letsencrypt_account_email=X
    does not do anything yet? LE just gets defaulted to admin email at this moment?
    Greetings, Richard.

  9. #9
    Join Date
    Nov 2016
    Posts
    23
    Quote Originally Posted by Richard G View Post
    Just to be sure:
    Code:
    letsencrypt_account_email=X
    does not do anything yet? LE just gets defaulted to admin email at this moment?
    I did check the letsencrypt.sh for using the option. But it didn't.

    Then saw:
    https://directadmin.com/features.php?id=2175

    So it no need anymore.

  10. #10
    Join Date
    Aug 2006
    Location
    LT, EU
    Posts
    7,245
    Quote Originally Posted by jordivn View Post
    Nice work on the skin!

    To enable it i go to reseller level -> skin manager. Why issn't there an skin manager on admin level?
    I would like to enable the skin server wide. there for i push "Set Global". But afther that. I go to admin level -> list of resellers -> just an reseller -> login. But then the old skin loads. How to fix?

    Jordi
    Just select "Apply to All Users". Skin is also set in user packages, so, I'd suggest changing it there so that when you create a new user, it would use Evolution instead of the other skin.
    Martynas Bendorius
    MB Martynas IT. Professional server management company. Official DirectAdmin, CloudLinux, LiteSpeed and Comodo partners.

  11. #11
    Join Date
    Nov 2016
    Posts
    23
    Did that, tanks for the tip.

  12. #12
    Quote Originally Posted by ditto View Post
    Regarding this feature: https://www.directadmin.com/features.php?id=2175 and regarding the option "letsencrypt_account_email=" you mention in reply #14 https://forum.directadmin.com/showth...919#post290919 and your reply #9 in https://forum.directadmin.com/showthread.php?t=56852

    We now have a situation where the new DirectAdmin version was released without any information and answers as to what have been done or not? We need answers on these:

    1: Does letsencrypt.sh 1.1.11 include support for letsencrypt_account_email= option?

    2: The email field is now removed from the SSL page https://www.directadmin.com/features.php?id=2175 - is it now needed to do a conversions for existing certificates?
    1) No, it was just added so that once we get the next LE version, it's ready to go without having to re-release DA. That's why there is no versions entry yet

    2) Ever since LE 1.1.11 came out, it was using a single key anyway, so clearing the email is more of a bug-fix to avoid confusion. There shouldn't have been an email field since then, as it didn't work as intended. The 1.1.11 came out to address the single-key functionality confusion (shouldn't have been the email field).
    Then the new letsencrypt_account_email option will eventually be added to the letsencrypt.sh to allow for the 3 scenarios described, but it's not done yet.

  13. #13
    Join Date
    Apr 2009
    Posts
    2,186
    @DirectAdmin Support, Thank you for the information. We did not upgrade to letsencrypt.sh 1.1.11, but are still on 1.1.10. We wanted to wait for the next DA version to be released, to be on the safe side.

    But we still need to know what happens to existing certificates installed before letsencrypt.sh 1.1.11 and before DirectAdmin 1.54? We need to know if they are going to be renewed with the users email, or if they are converted to a admin email automatically when they are renewed the next time? And will the old certificate expire if they are converted automatically? Also, if existing certificates are not automatically converted when they are up for renewal, how should be convert them manually?
    Last edited by ditto; 09-15-2018 at 11:59 PM.

  14. #14
    Join Date
    Jul 2011
    Posts
    114
    1.54.0 not working!

    It just freezes with the text Updating Directadmin and nothing is happening.

    The same issue with my 2 Debian 7 boxes!

    The update script should be more verbose, telling what its doing. And some kinf of progress bar would be nice.
    Last edited by jet1972; 09-16-2018 at 02:42 AM.
    End Times - Now! video (turn on English/French subtitles)

  15. #15
    Join Date
    Aug 2006
    Location
    LT, EU
    Posts
    7,245
    Quote Originally Posted by jet1972 View Post
    1.54.0 not working!

    It just freezes with the text Updating Directadmin and nothing is happening.

    The same issue with my 2 Debian 7 boxes!

    The update script should be more verbose, telling what its doing. And some kinf of progress bar would be nice.
    Please check /var/log/directadmin/error.log, I guess it might be a license-related issue. If you're unable to sort it out, just create a ticket at tickets.directadmin.com and it will be fixed free of charge
    Martynas Bendorius
    MB Martynas IT. Professional server management company. Official DirectAdmin, CloudLinux, LiteSpeed and Comodo partners.

  16. #16
    Join Date
    Jul 2011
    Posts
    114
    Hi.

    It started to work.

    I assume it was caused by high trafic on update servers.
    End Times - Now! video (turn on English/French subtitles)

  17. #17
    Join Date
    May 2018
    Posts
    4
    Unfortunately feature extended=yes for CMD_API_FTP doesn't work correctly.

    If by CMD_FTP I set ftp account suspended, CMD_FTP shows the ftp account is suspended and ftp account is really suspended but CMD_API_FTP (using extended=yes) returns suspended=no for this account.

    CMD_API_FTP returns suspended=no for all ftp accounts regardless if they are suspended or not.

  18. #18
    Quote Originally Posted by PerForumer View Post
    Unfortunately feature extended=yes for CMD_API_FTP doesn't work correctly.

    If by CMD_FTP I set ftp account suspended, CMD_FTP shows the ftp account is suspended and ftp account is really suspended but CMD_API_FTP (using extended=yes) returns suspended=no for this account.

    CMD_API_FTP returns suspended=no for all ftp accounts regardless if they are suspended or not.
    Terribly sorry about that.
    Bug found/fixed. It's now in the pre-release binaries, uploading now.
    Fix entry here:
    https://www.directadmin.com/features.php?id=2192

    John

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •