Results 1 to 3 of 3

Thread: Cannot install php7.2 (or any other) since upgrading to CustomBuild2.0

  1. #1
    Join Date
    Jan 2019
    Posts
    2

    Cannot install php7.2 (or any other) since upgrading to CustomBuild2.0

    Hi,

    My Debian 7 server was running DirectAdmin PHP 5.3 on Debian 7.

    I wanted to upgrade to PHP 7.2 so I first upgraded to custombuild2.0 and rebuild everything with ./build all d
    However it fails when setting up PHP with following error:

    Code:
    configure: error: Unable to find required gettext library
    
    *** There was an error while trying to configure php. Check the configure file
    I've seen this error on forums many times but non of the solutions worked.

    gettext is installed on my system: "gettext (GNU gettext-runtime) 0.18.1"
    custom build is 2.0.0 rev 1987

    I've tried PHP 5.6, 7.2 with mod_php and php-fpm but they all fail at this error.

    What am i missing? Any ideas?

  2. #2
    Join Date
    Aug 2006
    Location
    LT, EU
    Posts
    7,488
    Hello,

    I'd suggest checking https://help.directadmin.com/item.php?id=555 for upgrade instructions, especially this part:
    re-run the pre-install commands, in case you're missing something.
    Martynas Bendorius
    MB Martynas IT. Professional server management company. Official DirectAdmin, CloudLinux, LiteSpeed and Comodo partners.

  3. #3
    Join Date
    Jan 2019
    Posts
    2
    Quote Originally Posted by smtalk View Post
    Hello,

    I'd suggest checking https://help.directadmin.com/item.php?id=555 for upgrade instructions, especially this part:
    Hi. Thanks but I already did that prior to upgrade. I used that page for upgrade and have all re-run the pre-install commands.

    Any other idea?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •