Page 2 of 2 FirstFirst 12
Results 21 to 23 of 23

Thread: Upgrade MySql 5 to 8?

  1. #21
    Join Date
    Apr 2012
    Posts
    12
    Ah - you got me! I thought this was fixed in 1.57.1 (which I was running)... but the upgrade to 1.57.2 got it working.
    Thanks @smtalk - sorry for the bother

  2. #22
    Join Date
    Apr 2012
    Posts
    12
    Hi John,

    This works for the usual creating a user through the DA interface. However it's not working when I use admin backup and transfer to bring sites in from another server. Do the new user methods need to be implemented in the transfer functions of DA, or do I need to change a setting on the old server before creating the backup there?

  3. #23
    Join Date
    Nov 2016
    Posts
    29
    Hi Folks,

    I did update from 5.7 to 8.0.
    Besides that i run the follow php versions:
    php 7.2.20
    php2 7.1.30
    php3 7.3.7
    php4 7.0.33

    I updated everything with CB 2.0.

    I make use of Installatron to control applications on the server.
    After the update i get errors about the authentication (2054). This come from the new authentication proces of mysql 8 (sha265).

    As of the moment of writing, php mysqli doesn't support this by now. To fix this i set the follow in /etc/my.cnf and /etc/my.cnf.rpmnew:

    default-authentication-plugin=mysql_native_password

    This fixed the problems. I thought it is an nice fix to know for anyone who have the same issues.

Page 2 of 2 FirstFirst 12

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •