Results 1 to 3 of 3

Thread: Force_ssl_redirect

  1. #1
    Join Date
    Apr 2019
    Posts
    2

    Force_ssl_redirect

    Invalid command '|FORCE_SSL_REDIRECT|', perhaps misspelled or defined by a module not included in the server configuration
    After domain is added, apache is reloading and every domain has wrong configuration. Above error is appeared.

    Temporary resolve is to rebuild apache:
    ./build apache
    But true resolve is to add variable in config file:
    /usr/local/directadmin/conf/directadmin.conf
    force_ssl=yes
    Probably changing that value to 'no' would be proper also. After that restart DirectAdmin deamon.

    Related subject:
    https://www.directadmin.com/features.php?id=2221

    Reason of the problem. There is no default value of 'force_ssl' which was added on 2018-12-10.
    Related link:
    http://forum.directadmin.com/showthread.php?t=57251

  2. #2
    Join Date
    Aug 2006
    Location
    LT, EU
    Posts
    7,490
    It sounds like a binary/templates mismatch (new apache virtualhost templates with an old version of DA). Please let us know the output of:
    /usr/local/directadmin/directadmin v
    Martynas Bendorius
    MB Martynas IT. Professional server management company. Official DirectAdmin, CloudLinux, LiteSpeed and Comodo partners.

  3. #3
    Join Date
    Apr 2019
    Posts
    2
    /usr/local/directadmin/directadmin v
    Version: DirectAdmin v.1.56.1

    But as I already mentioned. I resolved problem by adding that variable. If you want I could hash it and check if problem still exist.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •