Results 1 to 5 of 5

Thread: May be you updated AWStats without updating browsers.pm file

  1. #1
    Join Date
    Mar 2019
    Posts
    10

    May be you updated AWStats without updating browsers.pm file

    Hello,

    I just updated AWStats, using Custombuild 2 interface. The installation finished without error "awstats_process.sh 2.9 has been installed."

    But then, when I try to visit the statistics page of a domain, I get the following errors:

    Error: Not same number of records of BrowsersSearchIDOrder (202 entries) and BrowsersHashIDLib (203 entries without firefox,opera,chrome,safari,konqueror,svn,msie,netscape) in Browsers database. May be you updated AWStats without updating browsers.pm file or you made changed into browsers.pm not correctly. Check your file /home/USER/domains/DOMAIN/public_html/awstats/lib/browsers.pm is up to date.

    Setup ('/home/USER/domains/DOMAIN/awstats/.data/awstats.DOMAIN.conf' file, web server or permissions) may be wrong.
    Check config file, permissions and AWStats documentation (in 'docs' directory).
    I searched a bit and I see that:

    The /home/USER/domains/DOMAIN/public_html/awstats/awstats.pl is new (2019)
    The /home/USER/domains/DOMAIN/public_html/awstats/lib/browsers.pm does not exist
    The ./usr/local/awstats-7.7/wwwroot/cgi-bin/lib/browsers.pm is old (2017) and
    The /home/USER/domains/DOMAIN/awstats/.data/awstats.kipi.gr.conf in new (2019)

    Please advise
    Kind Regards
    Elias

  2. #2
    Join Date
    Apr 2005
    Location
    GMT +7.00
    Posts
    12,940
    Hello Elias,

    I've got a synlink there:

    /home/USER/domains/DOMAIN/public_html/awstats/lib -> /usr/local/awstats/wwwroot/cgi-bin/lib

    so you might try as root in a shell run this command per domains/user:

    Code:
    ln -s /usr/local/awstats/wwwroot/cgi-bin/lib /home/USER/domains/DOMAIN/public_html/awstats/lib



    I don't recall doing it manually, so I believe it's Directadmin to care of it...

    Regards, Alex G.

    - You can hire me on www.poralix.com to work on your server
    - Follow and like @Poralix on Facebook

  3. #3
    Join Date
    Mar 2019
    Posts
    10
    Quote Originally Posted by zEitEr View Post
    Hello Elias,

    I've got a synlink there:

    /home/USER/domains/DOMAIN/public_html/awstats/lib -> /usr/local/awstats/wwwroot/cgi-bin/lib

    so you might try as root in a shell run this command per domains/user:

    Code:
    ln -s /usr/local/awstats/wwwroot/cgi-bin/lib /home/USER/domains/DOMAIN/public_html/awstats/lib



    I don't recall doing it manually, so I believe it's Directadmin to care of it...

    Thank you, sir!

  4. #4
    Join Date
    Mar 2019
    Posts
    10
    Hello,

    I upgraded the AWStats from within the Custombuild 2 plugin, on the 12th of April.
    And I set the correct link (what you proposed: ln -s /usr/local/awstats/wwwroot/cgi-bin/lib /home/USER/domains/DOMAIN/public_html/awstats/lib) on the 18th of April.

    From within DirectAdmin, by visiting the Webalizer (on the domain stats) I can see results from the 12th until today. Missing results before the 12th of April.
    From the domain.com/awstats, I can see all the old results until the 12th, then empty, and then results again from the 18th until today. Missing results starting on the upgrade and finishing when I set the correct link.

    How can I make both the domain.com/awstats and the Webalizer to see all the results from the past until today?

    Kind Regards
    Elias

  5. #5
    Join Date
    Apr 2005
    Location
    GMT +7.00
    Posts
    12,940
    By default directadmin keeps logs for last 5 days, to regenerate missing data you need

    1. unpack rotated logs
    2. make awstats/webalizer to process them

    Right now I don't have instructions on how to complete it. It's up to you to find them here or in internet.
    Regards, Alex G.

    - You can hire me on www.poralix.com to work on your server
    - Follow and like @Poralix on Facebook

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •