Results 1 to 3 of 3

Thread: php 7.3 build failed

  1. #1
    Join Date
    May 2013
    Location
    The Hague area, The Netherlands
    Posts
    69

    php 7.3 build failed

    Well, overwhelmed by number of log-lines I was happy with the last line: "Done!". But now I know it isn't done yet for me.

    I guess the main problem is "cannot create regular file '/usr/local/php73/lib/php.ini': No such file or directory"

    Why does this happen? It's a new 7.3 install by custom build. Should I add something maually?

    The last lines of my buildlog:
    Code:
    Copying php.ini..
    cp: cannot create regular file '/usr/local/php73/lib/php.ini': No such file or directory
    grep: /usr/local/php73/lib/php.ini: No such file or directory
    grep: /usr/local/php73/lib/php.ini: No such file or directory
    /usr/local/directadmin/custombuild/build: line 11432: [: : integer expression expected
    /usr/local/directadmin/custombuild/build: line 11435: [: : integer expression expected
    Can't open /usr/local/php73/lib/php.ini: No such file or directory.
    Can't open /usr/local/php73/lib/php.ini: No such file or directory.
    Enabling mail.add_x_header option in /usr/local/php73/lib/php.ini
    Can't open /usr/local/php73/lib/php.ini: No such file or directory.
    Can't open /usr/local/php73/lib/php.ini: No such file or directory.
    grep: /usr/local/php73/lib/php.ini: No such file or directory
    /usr/local/directadmin/custombuild/build: line 11447: [: -eq: unary operator expected
    /usr/local/directadmin/custombuild/build: line 9997: /usr/local/php73/bin/php-config: No such file or directory
    /usr/local/directadmin/custombuild/build: line 10011: /usr/local/php73/lib/php.conf.d/10-directadmin.ini: No such file or directory
    cp: cannot create regular file '/usr/local/php73/etc/php-fpm.conf': No such file or directory
    cp: cannot create regular file '/usr/local/php73/etc/php-fpm.conf': No such file or directory
    cp: cannot create regular file '/usr/local/php73/etc/php-fpm.conf': No such file or directory
    Can't open /usr/local/php73/etc/php-fpm.conf: No such file or directory.
    Enabling php-fpm73 in systemd...
    Created symlink from /etc/systemd/system/multi-user.target.wants/php-fpm73.service to /etc/systemd/system/php-fpm73.service.
    ln: failed to create symbolic link '/usr/local/php73/sbin/php-fpm': No such file or directory
    Job for php-fpm73.service failed because the control process exited with error code. See "systemctl status php-fpm73.service" and "journalctl -xe" for details.
    PHP 7.3.6 Installed.
    Done!
    Geert-Jan

    VPS, CentOS 7

  2. #2
    Join Date
    Aug 2006
    Location
    LT, EU
    Posts
    8,133
    May you create a ticket on this at tickets.directadmin.com with access details? Something is not alright on the system
    Martynas Bendorius
    MB Martynas IT. Professional server management company. Official DirectAdmin, CloudLinux, LiteSpeed and Comodo partners.

  3. #3
    Join Date
    May 2013
    Location
    The Hague area, The Netherlands
    Posts
    69

    PHP 7.3 is installed now

    Quote Originally Posted by smtalk View Post
    May you create a ticket on this at tickets.directadmin.com with access details? Something is not alright on the system
    Thanks to smtalk for figuring out that my custom configure.php73 in my ../custom/fpm folder was incorrect.

    But now my sites turn up with a 503 :

    Code:
    Service Unavailable
    The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.
    Additionally, a 503 Service Unavailable error was encountered while trying to use an ErrorDocument to handle the request.
    I see in my logs the reason:

    Code:
    [Sat Jun 29 00:14:12.564489 2019] [proxy:error] [pid 31397:tid 140319207163648] (111)Connection refused: AH02454: FCGI: attempt to connect to Unix domain socket /usr/local/php73/sockets/familiepes.sock (*) fail$
    As far as I can see this file is created by the latest DA release. And it looks "7.3" to me...

    I changed my sites back to using PHP 7.2 again.
    Last edited by Pzz; 06-29-2019 at 01:32 AM.
    Geert-Jan

    VPS, CentOS 7

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •