Results 1 to 12 of 12

Thread: CXS Setup Problem

  1. #1
    Join Date
    Jun 2019
    Posts
    7

    Exclamation CXS Setup Problem

    Hello

    I have this error.
    How can ı solve ?


    [root@srv155 ~]# perl cxsinstaller.pl ipv4
    OS: [CloudLinux release 7.6 (Vladimir Lyakhov) ] [ipv4]
    Unpacking new cxs package...

    Configuring for OS

    Running cxs DirectAdmin installer

    Installing cxs

    Check we're running as root

    Checking Perl modules...
    Can't locate Archive/Zip.pm in @INC (@INC contains: /etc/cxs /root/perl5/lib/perl5/5.16.3/x86_64-linux-thread-multi /root/perl5/lib/perl5/5.16.3 /root/perl5/lib/perl5/x86_64-linux-thread-multi /root/perl5/lib/perl5 /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at (eval 60) line 2.
    BEGIN failed--compilation aborted at (eval 60) line 2.

    Can't locate Linux/Inotify2.pm in @INC (@INC contains: /etc/cxs /root/perl5/lib/perl5/5.16.3/x86_64-linux-thread-multi /root/perl5/lib/perl5/5.16.3 /root/perl5/lib/perl5/x86_64-linux-thread-multi /root/perl5/lib/perl5 /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at (eval 64) line 2.
    BEGIN failed--compilation aborted at (eval 64) line 2.

    You need to install the missing perl modules and then install cxs
    Tidying up...
    ...All done.

  2. #2
    Join Date
    Jul 2017
    Location
    Murfreesboro
    Posts
    192
    Try installing these Perl modules

    yum install -y perl-Archive-Tar perl-IO-Zlib perl-Archive-Zip perl-Linux-Inotify2
    Thanks,
    Brent Dacus
    Just a regular guy from Tennessee

    CentOS 7 | DA | CB 2.0 | MariaDB 10.4 | PHP 7.2

  3. #3
    Join Date
    Jun 2019
    Posts
    7
    Hello

    Now this error.

    Error: Package: perl-Linux-Inotify2-1.21-3.el6.x86_64 (epel)
    Requires: perl(:MODULE_COMPAT_5.10.1)
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest

    Quote Originally Posted by bdacus01 View Post
    Try installing these Perl modules

    yum install -y perl-Archive-Tar perl-IO-Zlib perl-Archive-Zip perl-Linux-Inotify2

  4. #4
    Join Date
    Jul 2017
    Location
    Murfreesboro
    Posts
    192
    Quote Originally Posted by hostixo View Post
    Hello

    Now this error.

    Error: Package: perl-Linux-Inotify2-1.21-3.el6.x86_64 (epel)
    Requires: perl(:MODULE_COMPAT_5.10.1)
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest
    I see your on CentOS 6. I am on CentOS 7. I also didn’t use epel not that it should matter. It’s looking for a dependent package called module compat. Not sure as I don’t use CentOS 6
    Thanks,
    Brent Dacus
    Just a regular guy from Tennessee

    CentOS 7 | DA | CB 2.0 | MariaDB 10.4 | PHP 7.2

  5. #5
    Join Date
    Jun 2019
    Posts
    7
    it is cloudlinux 7.

    Quote Originally Posted by bdacus01 View Post
    I see your on CentOS 6. I am on CentOS 7. I also didnít use epel not that it should matter. Itís looking for a dependent package called module compat. Not sure as I donít use CentOS 6

  6. #6
    Join Date
    Apr 2005
    Location
    GMT +7.00
    Posts
    13,311
    You should not have perl-Linux-Inotify2-1.21-3.el6.x86_64 (epel) on CentOS 7.x

    Check
    /etc/yum.repos.d/epel.repo and make sure you have repositories for 7 connected.
    Regards, Alex G.

    - Get the best commercial DirectAdmin support and hire me on poralix.com
    - Follow and like @Poralix on Facebook

  7. #7
    Join Date
    Jul 2017
    Location
    Murfreesboro
    Posts
    192
    Quote Originally Posted by hostixo View Post
    it is cloudlinux 7.
    Like Alex said you have your os and repos all messed up or something. Did you install a full CL install as 7? then you set a EPEL repo as version 6...
    Thanks,
    Brent Dacus
    Just a regular guy from Tennessee

    CentOS 7 | DA | CB 2.0 | MariaDB 10.4 | PHP 7.2

  8. #8
    Join Date
    Jun 2019
    Posts
    23
    run

    Code:
    rm  /etc/yum.repos.d/epel.repo
    and confirm deletion

    Code:
    yum clean all
    Code:
    yum install epel-release
    and then try
    Code:
    yum install -y perl-Archive-Tar perl-IO-Zlib perl-Archive-Zip perl-Linux-Inotify2

  9. #9
    Join Date
    Jun 2019
    Posts
    7
    Same error.

    Checking Perl modules...
    Can't locate Linux/Inotify2.pm in @INC (@INC contains: /etc/cxs /root/perl5/lib/perl5/5.16.3/x86_64-linux-thread-multi /root/perl5/lib/perl5/5.16.3 /root/perl5/lib/perl5/x86_64-linux-thread-multi /root/perl5/lib/perl5 /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at (eval 66) line 2.
    BEGIN failed--compilation aborted at (eval 66) line 2.


    Quote Originally Posted by DanielP View Post
    run

    Code:
    rm  /etc/yum.repos.d/epel.repo
    and confirm deletion

    Code:
    yum clean all
    Code:
    yum install epel-release
    and then try
    Code:
    yum install -y perl-Archive-Tar perl-IO-Zlib perl-Archive-Zip perl-Linux-Inotify2

  10. #10
    Join Date
    Apr 2005
    Location
    GMT +7.00
    Posts
    13,311
    Will
    Code:
    yum check
    show any error?

    And will
    Code:
    yum update
    resolve conflicts?
    Regards, Alex G.

    - Get the best commercial DirectAdmin support and hire me on poralix.com
    - Follow and like @Poralix on Facebook

  11. #11
    Join Date
    Jun 2019
    Posts
    7
    Now ı have installed.


    yum -y install perl-libwww-perl.noarch
    yum -y install perl-LWP-Protocol-https.noarch
    yum -y install perl-Archive-Tar.noarch
    yum -y install perl-Archive-Zip.noarch
    yum -y install perl-Linux-Inotify2
    yum -y install perl-Compress-Zlib
    yum -y install sqlite
    yum -y install perl-DBI
    yum -y install perl-DBD-SQLite




    Quote Originally Posted by zEitEr View Post
    Will
    Code:
    yum check
    show any error?

    And will
    Code:
    yum update
    resolve conflicts?

  12. #12
    Join Date
    Jul 2017
    Location
    Murfreesboro
    Posts
    192
    Great does it work now? I think you have to set up the clamd socket as well.
    Thanks,
    Brent Dacus
    Just a regular guy from Tennessee

    CentOS 7 | DA | CB 2.0 | MariaDB 10.4 | PHP 7.2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •