Results 1 to 6 of 6

Thread: Adding User Hanging

  1. #1
    Join Date
    Aug 2019
    Posts
    6

    Adding User Hanging

    New to DA but not other cp's and I have it installed ok.

    Problem seems to be that when I add a user the screen seems to hang up and I don't get a success screen or change in screen.
    The screen just remains like a frosted overlay. However the user appears to be created ok after I finally refresh or close the browser.

  2. #2
    Join Date
    Jun 2019
    Posts
    115
    Do you have any user_create_pre.sh, user_create_post.sh, domain_create_pre.sh, or domain_create_post.sh (or maybe others) in your /usr/local/directadmin/scripts/custom directory?

  3. #3
    Join Date
    Aug 2019
    Posts
    6
    [root@server ~]# cd /usr/local/directadmin/scripts/custom
    [root@server custom]# ls
    block_ip.sh README unblock_ip.sh
    brute_force_notice_ip.sh show_blocked_ips.sh

  4. #4
    Join Date
    Aug 2019
    Posts
    6
    I have this :

    [root@server ~]# cd /usr/local/directadmin/scripts/custom
    [root@server custom]# ls
    block_ip.sh README unblock_ip.sh
    brute_force_notice_ip.sh show_blocked_ips.sh

  5. #5
    Join Date
    Aug 2019
    Posts
    6
    It finally went through after about 1.5 minutes with a quota not enabled error on my last attempt.

  6. #6
    Join Date
    Aug 2019
    Posts
    6
    I am running Centos 7.6 and found my fix
    -------------
    Unix User created successfully

    User's System Quotas set
    User's data directory created successfully
    Domains directory created successfully
    Domains directory created successfully in user's home

    User added to named.conf file successfully
    ------------------

    In case others have this issue Here is the fix:

    # mount | grep ' / '

    Centos 7 was:
    /dev/mapper/centos_server-root on / type xfs (rw,relatime,attr2,inode64,noquota)


    Use vi or nano (which I prefer) to edit /etc/default/grub

    Look for something like this:
    GRUB_CMDLINE_LINUX="crashkernel=auto rd.lvm.lv=centos_server/root rd.lvm.lv=centos_server/swap rhgb quiet"

    Add rootflags=uquota,pquota at the end to look like this:
    GRUB_CMDLINE_LINUX="crashkernel=auto rd.lvm.lv=centos_server/root rd.lvm.lv=centos_server/swap rhgb quiet rootflags=uquota,pquota"

    After you save the file make a copy of the grub.cfg in case your server crashes
    cp /boot/grub2/grub.cfg /boot/grub2/grub.cfg.orig

    Then make your new grub.cfg
    grub2-mkconfig -o /boot/grub2/grub.cfg

    Reboot the server

    # mount | grep ' / ' should be like this now:
    /dev/mapper/centos_server-root on / type xfs (rw,relatime,attr2,inode64,usrquota,prjquota)

    The quota error is now gone

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •