Page 1 of 2 12 LastLast
Results 1 to 20 of 27

Thread: debian 10 alpha testing

  1. #1
    Join Date
    Jan 2004
    Posts
    184

    debian 10 alpha testing

    Hello,
    directadmin have release a alpha version of debian 10.
    I have make a basic install. it is finished without problems (with the default setup).
    i have setup a domain, and seems all is fine.
    So we are in good road
    now i am checking customized installations/upgrades to see for any bug.

    Thank you directadmin team!!!

  2. #2
    Join Date
    Jan 2004
    Posts
    184
    Also may is the right time to create a debian 10 forum and move this post here?

  3. #3
    Join Date
    Jan 2018
    Posts
    27
    Quote Originally Posted by blueice View Post
    Hello,
    directadmin have release a alpha version of debian 10.
    I have make a basic install. it is finished without problems (with the default setup).
    i have setup a domain, and seems all is fine.
    So we are in good road
    now i am checking customized installations/upgrades to see for any bug.

    Thank you directadmin team!!!
    please share the testing results. thanks!

  4. #4
    Join Date
    Jan 2004
    Posts
    184
    i provide soon more details

  5. #5
    Join Date
    Jul 2011
    Posts
    162
    Well, not working so good here:

    There are several errors:

    chown: invalid user: 'directadmin:directadmin'

    Can't open /usr/local/directadmin/data/admin/services.status: no such file or directory
    End Times - Now! video (turn on English/French subtitles)

  6. #6
    Join Date
    Jan 2004
    Posts
    184
    Quote Originally Posted by jet1972 View Post
    Well, not working so good here:

    There are several errors:

    chown: invalid user: 'directadmin:directadmin'

    Can't open /usr/local/directadmin/data/admin/services.status: no such file or directory
    strange, can you please provide us the installation log? I think i can find why.
    Also you have install all the pre-install packages?

  7. #7
    Join Date
    Jan 2004
    Posts
    184
    Quote Originally Posted by blueice View Post
    strange, can you please provide us the installation log? I think i can find why.
    Also you have install all the pre-install packages?
    also please make sure that you have select debian 10 alpha in your license

  8. #8
    Join Date
    Jan 2004
    Posts
    184
    i have install with custombuild the bellow and everything go well
    I do soon more tests but seems the debian 10 support is now beta, not alpha


    php1_release=7.2
    php1_mode=php-fpm
    php2_release=7.0
    php2_mode=php-fpm
    php3_release=5.6
    php3_mode=php-fpm
    php4_release=7.3
    php4_mode=php-fpm
    opcache=yes
    php_ini=yes
    ioncube=yes
    zend=yes
    mariadb=10.4
    mysql_inst=mariadb
    clamav=yes
    clamav_exim=yes
    blockcracking=yes
    easy_spam_fighter=yes
    spamd=spamassassin

  9. #9
    Join Date
    Jul 2011
    Posts
    162
    Hi. Yes I had installed pre-install packages and set Debian 10 alpha in license
    End Times - Now! video (turn on English/French subtitles)

  10. #10
    Join Date
    Jan 2004
    Posts
    184
    Quote Originally Posted by jet1972 View Post
    Hi. Yes I had installed pre-install packages and set Debian 10 alpha in license
    if you provide the installation log i can debug why this happen to your server.
    my test is in KVM vps

  11. #11
    Join Date
    Jul 2011
    Posts
    162
    Hi.

    Where can one see the complete installation log?

    There is not much in /var/log/directadmin/install.log
    End Times - Now! video (turn on English/French subtitles)

  12. #12
    Join Date
    Jan 2004
    Posts
    184
    in fresh debian install do this:
    https://putty.org.ru/articles/captur...ssion-log.html

    also tell us more info about the server you use. plain metal?brand model? KVM? openvz? or?
    In case you have a test vps and you want i can also make a try, because i think i can fix the possible problem

  13. #13
    Join Date
    Feb 2005
    Location
    The Netherlands
    Posts
    386
    They opened up a new board for Beta testing here: https://forum.directadmin.com/forumdisplay.php?f=99
    Prism Open Source - DirectAdmin hosting since 2004

  14. #14
    Join Date
    Jan 2004
    Posts
    184
    yes, maybe the admins can move this thread there?

  15. #15
    Join Date
    Jul 2011
    Posts
    162
    Hi. There is this in very early state of the install: "chown: invalid user: ‘diradmin:diradmin’"

    I wll send the full log if this is not sorted out with this info:


    /usr/local/directadmin/update.tar.gz 100%[+++++++++++++++++++++++++===============================================================>] 8.61M 420KB/s in 46s

    2019-09-13 14:10:10 (135 KB/s) - ‘/usr/local/directadmin/update.tar.gz’ saved [9023939/9023939]

    Added 'allow-transfer { none; };' to /etc/bind/named.conf.options
    --2019-09-13 14:10:10-- http://216.144.255.179/named.ca
    Connecting to 216.144.255.179:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 2769 (2.7K)
    Saving to: ‘/etc/bind/named.ca’

    /etc/bind/named.ca 100%[========================================================================================>] 2.70K --.-KB/s in 0.002s

    2019-09-13 14:10:10 (1.28 MB/s) - ‘/etc/bind/named.ca’ saved [2769/2769]

    All Checks have passed, continuing with install...
    chown: invalid user: ‘diradmin:diradmin’
    chown: invalid user: ‘diradmin:diradmin’
    chown: invalid user: ‘diradmin:diradmin’
    Created symlink /etc/systemd/system/multi-user.target.wants/directadmin.service → /etc/systemd/system/directadmin.service.
    Created symlink /etc/systemd/system/multi-user.target.wants/startips.service → /etc/systemd/system/startips.service.
    Checking quotas...
    Running quotacheck
    done
    Done quotacheck
    --2019-09-13 14:10:11-- https://www.directadmin.com/cgi-bin/...xxx&uid=xxxxxx
    Resolving www.directadmin.com (www.directadmin.com)... 216.144.255.179
    Connecting to www.directadmin.com (www.directadmin.com)|216.144.255.179|:443... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: unspecified [application/octet-stream]
    Saving to: ‘/usr/local/directadmin/conf/license.key’

    /usr/local/directadmin/conf/license.key [ <=> ] 1.52K --.-KB/s in 0s

    2019-09-13 14:10:12 (32.3 MB/s) - ‘/usr/local/directadmin/conf/license.key’ saved [1559]

    chown: invalid user: ‘diradmin:diradmin’
    --2019-09-13 14:10:12-- http://files6.directadmin.com/servic...n100_64.tar.gz
    Resolving files6.directadmin.com (files6.directadmin.com)... 62.148.174.106, 2001:16e8:1:c:62:148:174:106
    Connecting to files6.directadmin.com (files6.directadmin.com)|62.148.174.106|:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 734628877 (701M) [application/x-gzip]
    Saving to: ‘/usr/local/directadmin/scripts/packages/services.tar.gz’
    Last edited by jet1972; 09-13-2019 at 11:55 AM.
    End Times - Now! video (turn on English/French subtitles)

  16. #16
    Join Date
    Jul 2011
    Posts
    162
    Tried once again DA installation on Debian 10. I get weird pauses during loading the components.. It seems to get stuck on random packages. Now it got stuck on loading roundcube 0.8.6.

    And why does DA even try to load (and install?) such an old version of Roudncube??
    Last edited by jet1972; 09-13-2019 at 08:51 AM.
    End Times - Now! video (turn on English/French subtitles)

  17. #17
    Join Date
    Jul 2011
    Posts
    162
    These weird pauses happens occasionally on Debian 7 box too.

    Usually the loading eventually continues.

    This pausing behaviour is strage and it seems to happen with all mirrors.

    What is causing it? Anyone else having this issue?
    End Times - Now! video (turn on English/French subtitles)

  18. #18
    Join Date
    Jul 2011
    Posts
    162
    It seems that the problem that causes errors like chown: invalid user: ‘diradmin:diradmin’ is caused Debian 10 now handles paths.

    The fix seems to be to execute command:

    su -

    before installation.

    After that I managed to install DA on Debian 10.1

    However I got this at the end of installation:
    "Got signal 13 during installation!"

    and the install script did not exit and I had to use ctrl-c to get back to shell.


    https://bugs.debian.org/cgi-bin/bugr...cgi?bug=918754
    Last edited by jet1972; 09-13-2019 at 10:27 AM.
    End Times - Now! video (turn on English/French subtitles)

  19. #19
    Join Date
    Jul 2011
    Posts
    162
    Now it stalled on webalizer


    adding gd ...
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Unable to locate package gd
    --2019-09-13 20:55:33-- http://files.directadmin.com/service...0_64/webalizer
    Resolving files.directadmin.com (files.directadmin.com)... 208.167.226.3, 104.128.54.74, 69.162.69.58
    Connecting to files.directadmin.com (files.directadmin.com)|208.167.226.3|:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 1792713 (1.7M)
    Saving to: ‘/usr/bin/webalizer’

    /usr/bin/webalizer 80%[===============================================> ] 1.37M --.-KB/s eta 6m 15s


    10 minutes and nothing happen..

    I can access webpages at the same time thru Lynx so the connection is workig..
    End Times - Now! video (turn on English/French subtitles)

  20. #20
    Join Date
    Jul 2011
    Posts
    162
    Continued after 20 minutes:


    --2019-09-13 21:45:15-- https://www.directadmin.com/cgi-bin/...xx&redirect=ok
    Resolving www.directadmin.com (www.directadmin.com)... 216.144.255.179
    Connecting to www.directadmin.com (www.directadmin.com)|216.144.255.179|:443... connected.
    HTTP request sent, awaiting response...
    HTTP/1.1 302 Found
    Date: Fri, 13 Sep 2019 18:45:15 GMT
    Server: Apache/2
    x-return-code: redirect
    Connection: close
    x-md5: 79553dd232153ee9ab7f7d1a26873007
    Location: http://69.162.69.58/stable_releases_...n100_64.tar.gz
    Content-Length: 330
    Content-Type: text/html; charset=iso-8859-1
    Location: http://69.162.69.58/stable_releases_...n100_64.tar.gz [following]
    --2019-09-13 21:45:15-- http://69.162.69.58/stable_releases_...n100_64.tar.gz
    Connecting to 69.162.69.58:80... connected.
    HTTP request sent, awaiting response...
    HTTP/1.1 200 OK
    Date: Fri, 13 Sep 2019 18:45:16 GMT
    Server: Apache/2
    Last-Modified: Wed, 28 Aug 2019 00:17:33 GMT
    ETag: "89b1c3-5912250bc8140"
    Accept-Ranges: bytes
    Content-Length: 9023939
    Vary: User-Agent
    Keep-Alive: timeout=2, max=100
    Connection: Keep-Alive
    Content-Type: application/x-gzip
    Content-Encoding: x-gzip
    Length: 9023939 (8.6M) [application/x-gzip]
    Saving to: ‘/usr/local/directadmin/update.tar.gz’

    /usr/local/directadmin/update.tar.gz 33%[=========================> ] 2.86M --.-KB/s in 3m 7s

    2019-09-13 21:48:23 (15.7 KB/s) - Read error at byte 2995589/9023939 (Connection timed out). Retrying.

    --2019-09-13 21:48:24-- (try: 2) http://69.162.69.58/stable_releases_...n100_64.tar.gz
    Connecting to 69.162.69.58:80... connected.
    HTTP request sent, awaiting response...
    HTTP/1.1 206 Partial Content
    Date: Fri, 13 Sep 2019 18:48:24 GMT
    Server: Apache/2
    Last-Modified: Wed, 28 Aug 2019 00:17:33 GMT
    ETag: "89b1c3-5912250bc8140"
    Accept-Ranges: bytes
    Content-Length: 6028350
    Vary: User-Agent
    Content-Range: bytes 2995589-9023938/9023939
    Keep-Alive: timeout=2, max=100
    Connection: Keep-Alive
    Content-Type: application/x-gzip
    Content-Encoding: x-gzip
    Length: 9023939 (8.6M), 6028350 (5.7M) remaining [application/x-gzip]
    Saving to: ‘/usr/local/directadmin/update.tar.gz’

    /usr/local/directadmin/update.tar.gz 47%[++++++++++++++++++++++++++==========>
    End Times - Now! video (turn on English/French subtitles)

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •