1.62.0 RC1 - Compiled Jun 3 2021, 13:35:25 - Evolution Skin Problem

cjd

Verified User
Joined
Feb 1, 2021
Messages
153
Location
Canada
Having an issue with the Evolution skin showing a user.

All testing done as Admin

User Manager -> Show All Users -> click on a user name

Draws blank area instead of showing that users information.

Browser console has the following error:

Code:
vendors.js?ver=master-144:19 TypeError: Cannot read property 'userData' of undefined
    at a (14.js?3609e8e55e0faebe7cc8:1)
    at a.t._render (vendors.js?ver=master-144:19)
    at a.r (vendors.js?ver=master-144:19)
    at pn.get (vendors.js?ver=master-144:19)
    at new pn (vendors.js?ver=master-144:19)
    at vendors.js?ver=master-144:19
    at a.xn.$mount (vendors.js?ver=master-144:19)
    at a.xn.$mount (vendors.js?ver=master-144:19)
    at init (vendors.js?ver=master-144:19)
    at n (vendors.js?ver=master-144:19)
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
10,282
Location
LT, EU
I was unable to reproduce it, may you try updating pre-release again?
 

cjd

Verified User
Joined
Feb 1, 2021
Messages
153
Location
Canada
I was unable to reproduce it, may you try updating pre-release again?

Just tested it again with Build:Jun 4 2021, 00:12:38

Same result. Just tested on Chromium, Chrome, FireFox (Noticed auto Dark Mode only works on FireFox) and Brave Browsers (on Ubuntu 20.04). First time for most of them so nothing was cached, and I also used web developer mode with cache disabled.

The JSON response from the CMD_SHOW_USER looks to be correct. Header section shows up fine, but the main/section (class="route-container...) only has <!----> in it with no content.
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
10,282
Location
LT, EU
Just tested it again with Build:Jun 4 2021, 00:12:38

Same result. Just tested on Chromium, Chrome, FireFox (Noticed auto Dark Mode only works on FireFox) and Brave Browsers (on Ubuntu 20.04). First time for most of them so nothing was cached, and I also used web developer mode with cache disabled.

The JSON response from the CMD_SHOW_USER looks to be correct. Header section shows up fine, but the main/section (class="route-container...) only has <!----> in it with no content.
May you PM full JSON? Thank you!
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
10,282
Location
LT, EU
I've found /usr/local/directadmin/data/templates/assets, renamed it to /usr/local/directadmin/data/templates/assets_backup
 

hrisafis

Verified User
Joined
Jan 16, 2020
Messages
8
Hello all, I have the same exact problem when I click on a user name under the list of users. I am on version 1.62.7

TypeError: Cannot read property 'userData' of undefined
at a.suspended (11.js?8a8fd80c823a380390cf:1)
at pn.get (vendors.js?ver=3313:19)
at pn.evaluate (vendors.js?ver=3313:19)
at a.suspended (vendors.js?ver=3313:19)
at a (11.js?8a8fd80c823a380390cf:1)
at a.t._render (vendors.js?ver=3313:19)
at a.r (vendors.js?ver=3313:19)
at pn.get (vendors.js?ver=3313:19)
at new pn (vendors.js?ver=3313:19)
at vendors.js?ver=3313:19

Checked already and there is no /usr/local/directadmin/data/templates/assets

Any thoughts? I want to modify a user and I can't.

Thank you in advance.
 

hrisafis

Verified User
Joined
Jan 16, 2020
Messages
8
Please guys, any help with the above would be highly appreciated!
Thanks!
 
Top