550-Verification failed for <root@server.domain.nl>

Richard G

Verified User
Joined
Jul 6, 2008
Messages
4,384
Location
Maastricht
Installed a new VPS with external nameserver for a friend with personal license. But maybe I did something wrong, I normally never use external nameservers so in DA they are not mentioned.

CSF is trying to send mail to me, I get this on my mail addres:
Code:
SMTP error from remote mail server after RCPT TO:<systemmail@mycompany.nl>:
    550-Verification failed for <root@server.hobbydomain.nl>
    550-Unrouteable address
    550 Sender verify failed
Normally I run the newaliases command after making changes in /etc/aliases but seems this is not needed with exim and not installed anymore (can not be found).

I did copy the DKIM and SPF records to the DNS zone of the VPS provider. External tests do not show issues and DNS looks good.

So probably I need to point to the vps providers nameservers which are used, must be mentioned somewhere? Is that on user level in his domains dns settings?
Or somewhere else?
Or am I forgetting something else?
 

Richard G

Verified User
Joined
Jul 6, 2008
Messages
4,384
Location
Maastricht
Oke this is getting weird.
By the way... I did checked the help files but everything is fine.
Also with normal e-mails on mail-tester.com I get a 10/10 score and every mail, spf and dkim tester checks out fine.
It's only root@hostname which has this issue.

With Google I found this command on the forum:
echo test | mail -s test admin@domain.com
exigrep admin@domain.com /var/log/exim/mainlog

So I tested like this:
Code:
echo test | mail -s test root@server.hobbydomain.nl
exigrep admin@domain.com /var/log/exim/mainlog
And everything looked fine.

So I checked my company mail and indeed, no problem, no "unroutable" stuff. The mail arrived without any issues.

But when CSF sends an e-mail the problem occurs.
I don't have this on my own servers. They have the same exim.conf 4.5.

Strange, isn't it? Anybody a clue?
 

Richard G

Verified User
Joined
Jul 6, 2008
Messages
4,384
Location
Maastricht
FIXED!
Don't ask me how. After I did the above test now also CSF mails are send well, problem gone, don't ask me how. :cool:
 
Top