Anonymous FTP

k1l0b1t

New member
Joined
May 10, 2020
Messages
11
Location
Belgium
I wanted to create an anonymous ftp share to put some files up, but I can't seem to login with anonymous@domain.com (pure-ftpd)

I tried restarting pure-ftpd, but no success. Any tips how I get this working? (or how to add a read-only ftp user)
 

Richard G

Verified User
Joined
Jul 6, 2008
Messages
5,004
Location
Maastricht
But you did enable anonymous ftp access via the account?
Have you tried using username anonymous (without @domain.com) and password some email addres (even non existing) or anonymous@domain.com?
What dot he log files say when trying to connect?
 

k1l0b1t

New member
Joined
May 10, 2020
Messages
11
Location
Belgium
No, it still does not work. (The @domain.com is required because I'm using the server IP (My server only has 1 IP#). and whatever I enter as a password It does not work (I did "whitelist" my ip in CSF to be able to test). My FTP software says this, both with and without the @domain.com part:

Code:
Opdracht:    USER anonymous
Antwoord:    331 User anonymous OK. Password required
Opdracht:    PASS ***************************
Antwoord:    530 Login authentication failed
I think I'll just put the files up on a subdomain and add `Options +Indexes` to a .htaccess file, But it would still be nice to get anonymous FTP working.
 

bdacus01

Verified User
Joined
Jul 22, 2017
Messages
1,036
Location
Murfreesboro
It's not set up by default. Since Anonymus FTP is not looked as a good idea these days. So you will have to dig in a configure the system.

Start here:
Code:
cat /etc/pure-ftpd.conf |grep Anonymous
 

k1l0b1t

New member
Joined
May 10, 2020
Messages
11
Location
Belgium
Thx @bdacus01, I know anonymous ftp is a "bad" idea, but I just want to have it working (decided I'm not going to use it) I'll take a look at it later
 

Richard G

Verified User
Joined
Jul 6, 2008
Messages
5,004
Location
Maastricht
In the past there was a selection part in the enhanced skin for anonymous ftp, but it must be enabled, this was with proftpd.
There are some anonymous options in the pureftpd.conf where you can also point out if they may upload or only download.

I don't know if this enables things or choices on user level.

Please let us know your results after you have taken a look at it, because this question is asked more often and at this moment I don't have a testing server available. Maybe after the weekend I do.
 

k1l0b1t

New member
Joined
May 10, 2020
Messages
11
Location
Belgium
I did find an option "NoAnonymous yes", changed it to no, but no success. I think it was a proftpd thing that allowed read-only users. Logging in with "anonymous" works then, but that is not configured (I only have 1 IP) I thik anonymous ftp via the anonymous@domain.com was a proftpd feature. Anyways thanks for the help @Richard G and @bdacus01, not going to do too much to get somthing "just to work to have it working"
 

Richard G

Verified User
Joined
Jul 6, 2008
Messages
5,004
Location
Maastricht
You're welcome. As said with a bit of luck I will have a VPS for a few days which I can test with.
I'm still curious so I will do some tests myself, if I might get it to work (I have my doubts that I will) then I will post it here.
 

Richard G

Verified User
Joined
Jul 6, 2008
Messages
5,004
Location
Maastricht
Well I promised to do some tests myself and report back. And I found this:

However in my case minuid was already at 99 by default.
I added the cryptline in the directadmin.conf which also did not do any good.

The anonymous ftp user is added to the /etc/proftpd.passwd file, which also places it in the /etc/pureftpd.pdb file. I checked this and that part works.
Also tried to set the NoAnonymous to no in the puref-ftpd.conf to make things work.

However, I'm also only running into the authentication failures.

As this should work, I could be mistaken but seems to me you found a bug.
Good chance @smtalk or @DirectAdmin Support can fix this for you if you send in a ticket.
 

k1l0b1t

New member
Joined
May 10, 2020
Messages
11
Location
Belgium
Thanks for testing ;) .Except I have an internal licence trough my provider, so I can't send tickets to directadmin. And I'm using a directory with directory indexing enabled now, so anonymous FTP is not needed anymore. But thanks again for testing ;)
 

Richard G

Verified User
Joined
Jul 6, 2008
Messages
5,004
Location
Maastricht
You're welcome. However, I might have use for anonymous FTP for some accounts, it should be working some way.
So in that case I might send in a ticket if no answer is coming in this thread.

As for testing, you're welcome.
Also good to hear you found another solution.
 
Top