Anyone upgraded Exim on FreeBSD 4.9 yet?

i2iweb

Verified User
Joined
Feb 26, 2004
Messages
45
Location
Dallas, TX
Wanted to know what the ins and outs are before I attempt this myself. I'm currently using 4.24.
 

rhoekman

Verified User
Joined
Jan 3, 2004
Messages
250
Location
The Netherlands
I think you should ask the DA team for specific paths and compile options. EXIM is a custom package. I see the current version DA is using is 4.24 and the latest available version is 4.32. But if it ain't broke there's no need to fix it :)
 

jmstacey

Verified User
Joined
Feb 12, 2004
Messages
4,107
Location
Colorado
But sometimes you don't know its broken until its to late and your mail server has been comprised ;) So I'd also like to know how to update it. (also other software like mysql etc.)
 

rhoekman

Verified User
Joined
Jan 3, 2004
Messages
250
Location
The Netherlands
That is true but serious bug fixes or upgrades are already taken care of by DA. So if a security hole is in one of the custom packages like Exim or Mysql you will receive a patched/upgraded version. So that is what I actually ment with the "don't fix it if it is working".
 

nobaloney

NoBaloney Internet Svcs - In Memoriam †
Joined
Jun 16, 2003
Messages
26,119
Location
California
rhoekman said:
So if a security hole is in one of the custom packages like Exim or Mysql you will receive a patched/upgraded version.
Are you sure? I don't think so?

Hey John or Mark...

Please clarify... do you automaically install patched/upgraded versions of anything required by DA?

If not, do you have a security notification service?

Thanks.

Jeff
 

wdv

Verified User
Joined
Oct 22, 2003
Messages
163
John told me that they don't use the affected syntax in their config of exim. So DA's Exim config is not affected.
 

ProWebUK

Verified User
Joined
Jun 9, 2003
Messages
2,326
Location
UK
jlasman said:
Are you sure? I don't think so?

Hey John or Mark...

Please clarify... do you automaically install patched/upgraded versions of anything required by DA?

If not, do you have a security notification service?

Thanks.

Jeff
Updates are manual, either new rpms are placed on files.directadmin.com or the custom apache system is updated and you can run ./build clean ./build update to fix sort that :)

Notificiations - check my latest message in the custom apache thread and also take a look at http://optimum-servers.com/products/ for more information on that ;)

(DirectAssistant/DirectUpdate feature notes at the bottom of that page)

At the moment i'm doing numerous things to drastically increase the speed in which updates are available :)

Chris
 

lesmak

Verified User
Joined
May 1, 2004
Messages
32
I upgraded apache, thx.


"few" days passed, anyone upgraded exim in freebsd yet ?
 

i2iweb

Verified User
Joined
Feb 26, 2004
Messages
45
Location
Dallas, TX
Looks like I have to dust off my old test server and try this myself.

I'll post what I come up with.
 
Top