Apache 2.4.1 update - URGENT-

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
8,342
Location
LT, EU
Code:
buildconf: You need autoconf 2.59 or lower to build this version of PHP.            You are currently trying to use 2.63            Most distros have separate autoconf 2.13 or 2.59 packages.
Is the problem. It doesn't work properly with autoconf >2.59. I may add more checks to CB for it or re-add a PHP tarballs with a fixed "configure" file.
 

NoBaloney2

NoBaloney Internet Svcs.
Joined
Jun 17, 2007
Messages
498
Location
California
I've responded to your email. Can I somehow get the old version of autoconf through custombuild?

Thanks.

Jeff
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
8,342
Location
LT, EU
I've responded to your email. Can I somehow get the old version of autoconf through custombuild?

Thanks.

Jeff
There is no autoconf <2.61 available on DA servers, however, your server runs CentOS 6.2 (default autoconf is 2.63), but it has an autoconf-213 package, which can be installed using yum (yum install autoconf-213).
 

nobaloney

NoBaloney Internet Svcs - In Memoriam †
Joined
Jun 16, 2003
Messages
26,119
Location
California
There is no autoconf <2.61 available on DA servers, however, your server runs CentOS 6.2 (default autoconf is 2.63), but it has an autoconf-213 package, which can be installed using yum (yum install autoconf-213).
Thanks!

Jeff
 

Quonos

Verified User
Joined
Jul 30, 2009
Messages
23
Code:
buildconf: You need autoconf 2.59 or lower to build this version of PHP.            You are currently trying to use 2.63            Most distros have separate autoconf 2.13 or 2.59 packages.
Is the problem. It doesn't work properly with autoconf >2.59. I may add more checks to CB for it or re-add a PHP tarballs with a fixed "configure" file.
Just repackage PHP with the fixed file. It's faster, and has far less dependencies.
 

Terrorhawk

Verified User
Joined
Jan 29, 2007
Messages
32
yum install autoconf213
export PHP_AUTOCONF=/usr/bin/autoconf-2.13

this fixed to the problem for me on centos 6.2
 

Anton

Verified User
Joined
Oct 6, 2010
Messages
104
Location
Iceland
Code:
Stopping httpd:                                            [  OK  ]
Starting httpd: [Thu Sep 19 18:04:10.793587 2013] [core:warn] [pid 27795] AH00117: Ignoring deprecated use of DefaultType in line 61 of /etc/httpd/conf/httpd.conf.
This is the error i am getting ? after upgrade or i did first the upgrade and then read on the forum if this happend then you should delete custombuild and reinstall it so i did that but i am still getting the error ? any ideas.
 

ditto

Verified User
Joined
Apr 27, 2009
Messages
2,466
Code:
Stopping httpd:                                            [  OK  ]
Starting httpd: [Thu Sep 19 18:04:10.793587 2013] [core:warn] [pid 27795] AH00117: Ignoring deprecated use of DefaultType in line 61 of /etc/httpd/conf/httpd.conf.
This is the error i am getting ? after upgrade or i did first the upgrade and then read on the forum if this happend then you should delete custombuild and reinstall it so i did that but i am still getting the error ? any ideas.
I have not read this old thread, but it does not sound like a good idea to delete "custombuild". Try this instead:

Code:
cd /usr/local/directadmin/custombuild
./build update
./build rewrite_confs
 

Bjw4253

New member
Joined
Jan 22, 2010
Messages
3
Worked great

It is ready, but your configs are not. "custom" directory functionality is created for sysadmins (experts) only, you shouldn't use it. If you have an old configure.apache file, which is incompatible with apache 2.4, it won't work. CustomBuild doesn't touch "custom" directory at all. Do:
Code:
cd /usr/local/directadmin/custombuild
mv custom custom_not_used
./build apache
./build php n
And it will work with no problems.
How can I make my server worker?
Hello thank you for the help.I was trying to make mine from prefork to worker and this saved my butt.
I do have a question as It would not load the memcache modules because it could not use them from the extention directory.

I think it may be because of the headers in the php when I installed the custom apache.I did not run clean install on php but did on apache.

I just edited apache custom biuld in the ap2 and added "--with-mpm=worker" \

but it would not load the memcache or apc .

Any ideas as to what I could do to change my apache to worker?

Thank you
 
Top