Apache won't start.

millerdesign

Verified User
Joined
Sep 26, 2006
Messages
24
Location
Bristol, CT USA
I've can't get apache to start after custombuild.

Stopping httpd: [FAILED]
Starting httpd: Syntax error on line 43 of /etc/httpd/conf/httpd.conf:
Cannot load /usr/lib/apache/mod_suphp.so into server: /usr/lib/apache/mod_suphp.so: undefined symbol: apr_bucket_destroy_noop
[FAILED]

Here's my options I used.
mysql=5.0
default_php=4
php4_cli=no
php4_cgi=yes
php5_cli=no
php5_cgi=no
apache_ver=1.3
mail-header-patch=yes
dovecot=yes

Please help.
 

millerdesign

Verified User
Joined
Sep 26, 2006
Messages
24
Location
Bristol, CT USA
Well I changed options to:
mysql=5.0
default_php=4
php4_cli=yes
php4_cgi=no
php5_cli=no
php5_cgi=no
apache_ver=1.3
mail-header-patch=yes
dovecot=yes

./build update_data
./build clean
./build all d

And I got Apache up and running but I would still like to know if anyone has a clue why suphp wouldn't run.

mysql did not update to version 5.0
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
8,790
Location
LT, EU
You need to do this:
Code:
./build update
./build clean
rm -f /usr/lib/apache/mod_suphp.so
./build suphp
 

millerdesign

Verified User
Joined
Sep 26, 2006
Messages
24
Location
Bristol, CT USA
Another weird problem.

I added a sub domain today and it killed apache and would not restart. I got error message below:

Starting httpd: Syntax error on line 22 of /usr/local/directadmin/data/users/******/httpd.conf:
Invalid command 'SuexecUserGroup', perhaps mis-spelled or defined by a module not included in the server configuration

I searched the forum and resolved the problem with this:
echo "action=rewrite&value=httpd" >> /usr/local/directadmin/data/task.queue

But running this every time I add a domain will grow old quick, whats the fix for this?

options.conf
mysql=4.0
default_php=4
php4_cli=yes
php4_cgi=no
php5_cli=no
php5_cgi=no
apache_ver=1.3
mail-header-patch=yes
dovecot=yes
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
8,790
Location
LT, EU
Please post an output of:
Code:
cat /usr/local/directadmin/conf/directadmin.conf | grep apche_ver
 

millerdesign

Verified User
Joined
Sep 26, 2006
Messages
24
Location
Bristol, CT USA
Here's the output: apache_ver=1.3


The problem went away after I did this:
echo "action=rewrite&value=httpd" >> /usr/local/directadmin/data/task.queue
Creating domains no longer kills apache.


Quick question, what's the correct way to go from cli to cgi using custombuild?

do I:
./build update_data
./build clean
./build all d

or do I:

./build update
./build clean
./build suphp
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
8,790
Location
LT, EU
You just need to run this one-time (if you had suphp (manual install)):
Code:
./build suphp
Every time before any compilation it's suggested to run:
Code:
./build update
./build clean
To update the script and clean other compilations.

About the switch, you need to edit options.conf and set php5-cli to no, and php5-cgi to yes, then run:
Code:
./build php
 

drackox

Verified User
Joined
Oct 28, 2004
Messages
17
Here is what I did

I've can't get apache to start after custombuild.

Stopping httpd: [FAILED]
Starting httpd: Syntax error on line 43 of /etc/httpd/conf/httpd.conf:
Cannot load /usr/lib/apache/mod_suphp.so into server: /usr/lib/apache/mod_suphp.so: undefined symbol: apr_bucket_destroy_noop
[FAILED]
I just ran:

./build suphp

after you do that, it will fix the problem, but apache still may not start.

usually if that's the case, it's the ssl cert, and you just goto your /etc/httpd/conf/ssl.crt directory and rename the snakoil-ca-rsa.crt to server.crt
then goto /etc/httpd/conf/ssl.key directory and rename the snakeoil-ca-rsa.key to server.key

then enter service httpd restart
should work just fine after that.

If it doesnt, just past your error_log in here and i'm sure we'll figure it out!
 
Top