bind not reloading when modyfing DNS zone

wtptrs

Verified User
Joined
Jul 13, 2015
Messages
74
A customer complained the DNS records he added didn't seem to resolve. Directadmin logs are showing the following:

Code:
grep -i named /var/log/directadmin/errortaskq.log.1
2019:01:25-08:51:01: Error reloading service named : uid 0 gid 0 : /bin/systemctl reload named.service        >/dev/null 2>/dev/null                      : returned 1
2019:01:25-08:52:01: Error reloading service named : uid 0 gid 0 : /bin/systemctl reload named.service        >/dev/null 2>/dev/null                      : returned 1
2019:01:25-08:55:01: Error reloading service named : uid 0 gid 0 : /bin/systemctl reload named.service        >/dev/null 2>/dev/null                      : returned 1
2019:01:25-08:56:01: Error reloading service named : uid 0 gid 0 : /bin/systemctl reload named.service        >/dev/null 2>/dev/null                      : returned 1
2019:01:25-08:58:01: Error reloading service named : uid 0 gid 0 : /bin/systemctl reload named.service        >/dev/null 2>/dev/null                      : returned 1
2019:01:25-09:01:01: Error reloading service named : uid 0 gid 0 : /bin/systemctl reload named.service        >/dev/null 2>/dev/null                      : returned 1
2019:01:25-09:02:01: Error reloading service named : uid 0 gid 0 : /bin/systemctl reload named.service        >/dev/null 2>/dev/null                      : returned 1
2019:01:25-09:03:02: Error reloading service named : uid 0 gid 0 : /bin/systemctl reload named.service        >/dev/null 2>/dev/null                      : returned 1
2019:01:25-09:08:01: Error reloading service named : uid 0 gid 0 : /bin/systemctl reload named.service        >/dev/null 2>/dev/null                      : returned 1
2019:01:25-09:09:01: Error reloading service named : uid 0 gid 0 : /bin/systemctl reload named.service        >/dev/null 2>/dev/null                      : returned 1
Earlier logs are showing these entries as well.

I'm not able to reproduce this issue at this moment, when modifying the DNS-zone of the impacted user bind seems to be reload correctly by Directadmin. Any idea what could be the cause or where to look further?
 

zEitEr

Super Moderator
Joined
Apr 11, 2005
Messages
14,255
Location
GMT +7.00
Hello,

Check system logs for more details, probably an user's dns zone contained syntax errors, or other kind of errors which caused the issue.
 
Top