[Clamav-announce] announcing ClamAV 0.97.1

Meesterlijk

Verified User
Joined
Jan 19, 2007
Messages
179
Location
Netherlands

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
8,490
Location
LT, EU
A new ClamAV version should be uploaded to DA servers soon. You could use the following for now to update:
Code:
cd /usr/local/directadmin/custombuild
./build update
perl -pi -e 's/clamav:0.97:605ed132b2f8e89df11064adea2b183b/clamav:0.97.1:4f3fb74ff1098c25eef8e10721478c29/' versions.txt
wget -O clamav-0.97.1.tar.gz http://downloads.sourceforge.net/clamav/clamav-0.97.1.tar.gz
./build clamav
 

SeLLeRoNe

Super Moderator
Joined
Oct 9, 2004
Messages
6,791
Location
A Coruña, Spain
Thanks, worked perfectly on CentOS 5.6 64Bit.

Just an error on make (but seems that is working)

Code:
./build: line 7406: ldconfig: command not found
./build: line 7441: [: -eq: unary operator expected
./build: line 7448: [: -eq: unary operator expected
On second build worked perfectly.

Just something strange

Code:
>clamscan -V
ClamAV 0.97/12340/Tue Nov 30 13:19:00 2010
/custombuild]
>clamdscan -V
ClamAV 0.97/13177/Fri Jun 10 07:28:16 2011
Seems that ive 2 version instaleld, how i should check this and solve? Alraedy tryed via yum but isnt there.

Regards
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
8,490
Location
LT, EU
DirectAdmin uses /usr/sbin/clamd, while you might have an installation in /usr/local/sbin.

Thanks, worked perfectly on CentOS 5.6 64Bit.

Just an error on make (but seems that is working)

Code:
./build: line 7406: ldconfig: command not found
./build: line 7441: [: -eq: unary operator expected
./build: line 7448: [: -eq: unary operator expected
On second build worked perfectly.

Just something strange

Code:
>clamscan -V
ClamAV 0.97/12340/Tue Nov 30 13:19:00 2010
/custombuild]
>clamdscan -V
ClamAV 0.97/13177/Fri Jun 10 07:28:16 2011
Seems that ive 2 version instaleld, how i should check this and solve? Alraedy tryed via yum but isnt there.

Regards
 

SeLLeRoNe

Super Moderator
Joined
Oct 9, 2004
Messages
6,791
Location
A Coruña, Spain
Cause before start using custombuild for clamav ive used to use update.script

SO thats why i think ive a double copy...

Any idea about how reomve the unecessary copy?

Thanks
 

Remco00

Verified User
Joined
Feb 22, 2006
Messages
232
I would like to know as well how to delete the update.script version properly so I can install the custombuild clamav version instead.
 

SeLLeRoNe

Super Moderator
Joined
Oct 9, 2004
Messages
6,791
Location
A Coruña, Spain
As far as i remember the freshclam file is clamd-freshclam so should be found in the search.

If im wrong, so

Code:
find / -name freshclam*
Regards
 

Remco00

Verified User
Joined
Feb 22, 2006
Messages
232
Removed the old version and did u custombuild install. Only thing is that I freshclam won't start:

Restarting freshclam.
Code:
Shutting down freshclam:                                   [FAILED]
Starting freshclam: ERROR: Can't change dir to /var/lib/clamav
                                                           [FAILED]
 

Remco00

Verified User
Joined
Feb 22, 2006
Messages
232
Thanks, but it had to do with an old fresclam.conf file trhat was not properly deleted. Removed it and now all seems ok.
 
Top