custombuild apache failure

synergy

Verified User
Joined
Nov 8, 2003
Messages
48
Location
Australia
I am trying to update Apache from 2.2.14 to 2.2.16. I also added one option in custom/ap2/configure.apache which is "--enable-expires" as I want to add mod_expires functionality. I am running FreeBSD 7.2

The build process fails without many error messages. Is there someplace else to look for a better error message?

Making all in /usr
make: don't know how to make all. Stop
*** Error code 1
1 error
*** Error code 1
1 error

*** The make has failed, do you want to try to make again? (y,n)


Thanks for any help in advance.
 

nobaloney

NoBaloney Internet Svcs - In Memoriam †
Joined
Jun 16, 2003
Messages
26,119
Location
California
I've moved your thread; often FreeBSD related issues get faster response when in a FreeBSD subforum.

Jeff
 

DirectAdmin Support

Administrator
Staff member
Joined
Feb 27, 2003
Messages
8,931
Hello,

The actual error message is likely higher up. Paste us the last 2 pages of output when the script stops.

Note that missing \ characters are often the cause of issues when adding custom --items to the configure files. Failure to have a \ character at the line before the next will cause the script to run and run the next line as a command, instead of including it in the long line of options for the configure command.

John
 

daveyw

Verified User
Joined
Jan 5, 2008
Messages
702
Location
/dev/null
I guess you can better post us the output of
cat /usr/local/directadmin/custombuild/custom/ap2/configure.apache
I guess (exactly what John is saying) he added custom --item and forgot the \
 

synergy

Verified User
Joined
Nov 8, 2003
Messages
48
Location
Australia
1) I reverted my configure.apache and rolled my change out and still have the same issue.

2) I redirected stdout to a file, and the following error messages were sent to the shell

configure: WARNING: sys/syslimits.h: accepted by the compiler, rejected by the preprocessor!
configure: WARNING: sys/syslimits.h: proceeding with the compiler's result
gnome-config: not found
Package openssl was not found in the pkg-config search path.
Perhaps you should add the directory containing `openssl.pc'
to the PKG_CONFIG_PATH environment variable
No package 'openssl' found
cp: /usr is a directory (not copied).
printf %s\n: not found


Thanks for any advice in advance.
 
Top