DA on FreeBSD 6.0

jeffery

Verified User
Joined
Jan 13, 2004
Messages
279
Mark says no official support on FreeBSD 6.0, so your license will be FreeBSD 5.3/5.4.

1. Install Perl
2. Install Compat5x Port (/usr/ports/misc/compat5x)
3. echo compat5x_enable="YES" >> /etc/rc.conf
4. Run setup.sh and select freebsd51 package. (forgot the exact name.. :p)
5. Select the correct network interface.

Smooth install!

Will put more report on later tests.

:D
 
Last edited:

Sorantis

Verified User
Joined
Sep 29, 2005
Messages
11
Location
Georgia
I perfomed these steps, but unfortunately DA installation failed at finish.
The installer didn't generate the license.key file.
Mainly, it didn't fill it with any data (file is empty)
So , I rolled back to FreeBSD 5.4 ....
 

jeffery

Verified User
Joined
Jan 13, 2004
Messages
279
Sorantis said:
I perfomed these steps, but unfortunately DA installation failed at finish.
The installer didn't generate the license.key file.
Mainly, it didn't fill it with any data (file is empty)
So , I rolled back to FreeBSD 5.4 ....
Does DA able to start?

Try:
To update license: http://help.directadmin.com/item.php?id=30 (only if needed.. if it's 1298 bytes in size, it's fine)
 

Sorantis

Verified User
Joined
Sep 29, 2005
Messages
11
Location
Georgia
He is not able to start .Port 2222 is dead, but all other services are running , including Apache, WebMail.
After installation DA sends message, wich contains an occured error.
Something like, License key mismatch, or something else, I don't remember.


After this crash, I reinstalled FreeBSD , rolled back to 5,4 , and started DA setup.
And finished it successfully.
So, I guess we'll have to wait a bit , until Da would support FreeBSD 6.0....

P.S. : I don't think that changing license would fix this problem..
 
Last edited:

jeffery

Verified User
Joined
Jan 13, 2004
Messages
279
DA certainly won't start if the license file is incorrect. Our great John (DA guy) says regeting the license using the above method may fix the problem.

I personally didn't get this license error. Perhaps I will try to install it on different box to test more.

P.S. If all programs are running fine except DA, the thing you need to do is to let DA works! ;) Check the error logs.

:rolleyes:
 

Sorantis

Verified User
Joined
Sep 29, 2005
Messages
11
Location
Georgia
I already said that license.key file is empty ,what else is necessary? :)

But it doesn't metter anymore..for now ;)

I'm going to purchase one more DA for another services, and I'll try to use this feature with license regeting.
I don't know if ot would help, but I'll try.

If license was incorrect then why DA installation on BSD 5.4 was completed succesfully with the same license? :)
 

Chrysalis

Verified User
Joined
Aug 25, 2004
Messages
1,584
Location
uk
I have seen instances where the license retrieval fails with new wget, downloading the binary compiled by John seems to make the license download without error so I dont know if its either a incompatability with the newer wget or a option he added to wget compilation. But I would try using the wget here.

http://files.directadmin.com/services/freebsd5.1/wget
 

Sorantis

Verified User
Joined
Sep 29, 2005
Messages
11
Location
Georgia
I see...
Maybe You are right...I don't know , this attempt must be tested.
But what makes license download so problematic??
Why there is need to recompile wget??
 

dennisc

Verified User
Joined
Mar 14, 2005
Messages
75
Edit /usr/local/directadmin/scripts/getLicense.sh, change the "wget" commands in "wget --no-check-certificate" and run the script by hand.

Here FreeBSD 6.0 runs like a charm on all our DA servers.
 

Sorantis

Verified User
Joined
Sep 29, 2005
Messages
11
Location
Georgia
Do I need to run this script after DA installation?
And another question
If I'll copy the license.key generated on FreeBSD 5.4 to FreeBSD 6.0 , would it work??
 

dennisc

Verified User
Joined
Mar 14, 2005
Messages
75
Logically I'd say copying the key used on FreeBSD 5.x will work, not sure though. The script you need to run after the install if the 5.x key does not work.
 
Top