Debian 8 to Debian 9.4 + DA + exim

staff_nowa

Verified User
Joined
Mar 10, 2018
Messages
71
Hello everyone,

very interesting issue I found.

1. Upgraded Debian 8 to Debian 9.4
2. Installed required packages for DirectAdmin installation
3. Installed DirectAdmin
4. Exim installation is down. journalctl -xe return this error /usr/sbin/exim: error while loading shared libraries: libspf2.so.2: cannot open shared object file: No such file or directory
5. Checked /usr/local/directadmin/custombuild/options.conf
#Mail Settings
exim=no
eximconf=no
eximconf_release=4.5
blockcracking=no
easy_spam_fighter=no
spamd=no
sa_update=daily
dovecot=yes
dovecot_conf=yes
pigeonhole=no
6. Fix according https://help.directadmin.com/item.php?id=51
7. Tried to use ./build set eximconf_release 4.9, but only this option correct ./build set eximconf_release 4.5
8. Installed at result received message exim 4.9 installed.

It should be fixed in DirectAdmin installation.
 

staff_nowa

Verified User
Joined
Mar 10, 2018
Messages
71
I installed newest Debian then installed DirectAdmin. Issue not about Debian 8 DA -> upgrade to Debian 9 and change information about DA license.
 

zEitEr

Super Moderator
Joined
Apr 11, 2005
Messages
13,902
Location
GMT +7.00
Yes, those two are disabled by default even if you go manually through the installation process. Even if you choose custombuild to manage exim. Yes, it might need to be changed. So feel free to bring it to Directadmin developers' attention either by opening a ticket or sending a PM.
 
Top