DKIM breaked line

Ana Carolina

Verified User
Joined
May 3, 2018
Messages
18
Hi! I`m having this problem... trying to use e-goi newsletter system they ask for DKIM config. But the test said the DKIM value is broken line... How to fix it?

Should be like this: v=DKIM1; g=*; k=rsa; p=MIGfMA0GCSqGSIb3DQEBAQUAA4GNADCBiQKBgQDbx9jJyOqr7amc+wtRY1WxKb/8jj4EGEnGNj2kOUAMGBCW3TWWP5T5cDnP3V1rnnAlWn79P1jOIRFiRdwyVPuuHNJqIVhKsHPo5UV39nklDdjs6TfrP0IPGt8QdETP1z6bKBAhBGSRxnQlP3YIeKNOJcjpNoLXsVChWfdwe/K5fwIDAQAB

But it is like this: v=DKIM1; g=*; k=rsa; p=MIGfMA0GCSqGSIb3DQEBAQUAA4GNADCBiQKBgQDbx9jJyOqr7amc+wtRY1WxKb/8jj4EGEnGNj2kOUAMGBCW3TWWP5T5cDnP3V1rnnAlWn79P1jOIRFiRdwyVPuuHN
JqIVhKsHPo5UV39nklDdjs6TfrP0IPGt8QdETP1z6bKBAhBGSRxnQlP3YIeKNOJcjpNoLXsVChWfdwe/K5fwIDAQAB


see?? the space after the PuuHN ...

How can I fix it trought SSH?
 

Albert

Verified User
Joined
Oct 25, 2019
Messages
33
You can edit your DKIM key directly in your DirectAdmin interface => DNS management, here you will be able to change everything in your DNS Zone without SSH or command line.

When it's done, I strongly recommand you to check the FULL validity of your DKIM with this test
 

zEitEr

Super Moderator
Joined
Apr 11, 2005
Messages
13,854
Location
GMT +7.00
Hello,

Long DKIM lines in DNS always get space-separated. You might read more details here: https://serverfault.com/a/255676

If you have issues on validating a DKIM records from e-goi newsletter system, it might be due to the fact you are using a wrong selector in DNS. I guess you've replaced a value for a default x._domainkey record? But your service might require that you use another selector. Check with them.
 

Ana Carolina

Verified User
Joined
May 3, 2018
Messages
18
You can edit your DKIM key directly in your DirectAdmin interface => DNS management, here you will be able to change everything in your DNS Zone without SSH or command line.

When it's done, I strongly recommand you to check the FULL validity of your DKIM with this test
I can just delete and set a new one. I want to edit the field, to erase the space...
 

Ana Carolina

Verified User
Joined
May 3, 2018
Messages
18
Hello,

Long DKIM lines in DNS always get space-separated. You might read more details here: https://serverfault.com/a/255676

If you have issues on validating a DKIM records from e-goi newsletter system, it might be due to the fact you are using a wrong selector in DNS. I guess you've replaced a value for a default x._domainkey record? But your service might require that you use another selector. Check with them.
I saw that link... it is something like this... You think this option might work on DA?

"If you are using MySQL/MariaDB as your DNS backend, like PowerDNS you could resize your content column.

Default PowerDNS content length is VARCHAR(255)

So your DKIM signature will be trimmed off to 255 characters

to fix this

just change the content size via the MySQL CLI / MariaDB CLI

mysql -u root -p

USE powerdns;
alter table records modify column content text not null;
restart your DNS Service (eg PowerDNS)

service pdns restart"
 

Ana Carolina

Verified User
Joined
May 3, 2018
Messages
18
example

This is the e-goi error http://b8comunicacao.com.br/imagem/e-goi.png

This is my panel: http://b8comunicacao.com.br/imagem/panel.png

This was the answer from e-goi I translated to english on google so you can understand..... "Thanks for the return.



The information configured on your DKIM is entered correctly, in fact; however, your hosting is propagating this information with a break, as you can confirm from these two external validations: https://cl.ly/281f541dc537, https://cl.ly/1abd91f1cee0



You can also do this validation through the following link:



https://network-tools.com/nslookup/



This is a situation that has to be verified and corrected by your hosting technical support, as we have no control over how your hosting is propagated."
 

zEitEr

Super Moderator
Joined
Apr 11, 2005
Messages
13,854
Location
GMT +7.00
That's an Evolution skin of DirectAdmin. You can change a skin at a reseller level.
 

Albert

Verified User
Joined
Oct 25, 2019
Messages
33
You can try in your admin/reseller Interface

Server Manager => Administrator Settings => Server Settings => Document Root to Demo Skin = ./data/skins/evolution

If you don't want use SSH, you can use a Free "File Explorer" as WinSCP or Filezilla

Your file is located here : /etc/bind/
In this folder you will find the file that you want edit : Your-domain.com.db
But this is not really help if you don't want use SSH ! because you must restart BIND (DNS system) by SSH : "/etc/init.d/bind9 restart" to apply your changes.

Your acces with DA is level user ? or Reseller user ?
 

Ana Carolina

Verified User
Joined
May 3, 2018
Messages
18
You can try in your admin/reseller Interface

Server Manager => Administrator Settings => Server Settings => Document Root to Demo Skin = ./data/skins/evolution

If you don't want use SSH, you can use a Free "File Explorer" as WinSCP or Filezilla

Your file is located here : /etc/bind/
In this folder you will find the file that you want edit : Your-domain.com.db
But this is not really help if you don't want use SSH ! because you must restart BIND (DNS system) by SSH : "/etc/init.d/bind9 restart" to apply your changes.

Your acces with DA is level user ? or Reseller user ?
I'm reseller... the first option you gave will change the users or the reseller area to evolution too? because I installed the evolution trought the ssh and it not worked so good, the file was missing... but I could be back to enhance trought the reseller level...

do you know ssh code to install the revolution? So i can compare with the one I've testes to check why it was broken....
 

Albert

Verified User
Joined
Oct 25, 2019
Messages
33
Your file is located here : /etc/bind/
In this folder you will find the file that you want edit : Your-domain.com.db
you must restart BIND (DNS system) by SSH : "/etc/init.d/bind9 restart" to apply your changes.
If you used SSH, why you didn't made this above ? it's done and solved ?

Change the skin is not DKIM problem, you should open a new thread in this case.
 

Ana Carolina

Verified User
Joined
May 3, 2018
Messages
18
Looks like a problem on the system. Please try running DA in debug mode to see what’s the problem.
ebug mode. Level 2000

DirectAdmin 1.52.1
Accepting Connections on port 2222
Sockets::handshake - begin
Sockets::handshake - begin
Sockets::handshake - begin
Sockets::handshake - end
Sockets::handshake - end
Cannot find first space after where GET or POST should be
Cannot find first space after where GET or POST should be
Sockets::handshake - end
Cannot find first space after where GET or POST should be
Sockets::handshake - begin
Sockets::handshake - begin
Sockets::handshake - end
/HTM_INDEX_RESELLER
0: Accept-Encoding: gzip, deflate, br
1: Accept-Language: pt-BR,pt;q=0.9,en-US;q=0.8,en;q=0.7,fr;q=0.6,es;q=0.5,la;q=0.4
2: Accept: text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,image/apng,*/*;q=0.8,application/signed-exchange;v=b3
3: Connection: keep-alive
4: Cookie: mp_f48baf7f57bdb924fc68a786600d844e_mixpanel=%7B%22distinct_id%22%3A%20%22f7282cf462d4bf2849ed651ca8513a12%22%2C%22%24device_id%22%3A%20%2216ccfd5a8f4302-0e01267a6c396e-38637701-13c680-16ccfd5a8f57ab%22%2C%22%24user_id%22%3A%20%22f7282cf462d4bf2849ed651ca8513a12%22%2C%22%24initial_referrer%22%3A%20%22https%3A%2F%2F94.23.2.138%2F~nadiadra%2Fwp-admin%2Fplugins.php%3Fplugin_status%3Dall%26paged%3D1%26s%22%2C%22%24initial_referring_domain%22%3A%20%2294.23.2.138%22%7D; wpglobus-language-old=en; wpglobus-language=en; session=w4gQyJkj2RMA03PgfiZQNrjDfSZd8mj2qOSmhBWjcsrbvEFYwowIfgVJ85wFpdHd
5: Host: 94.23.2.138:2222
6: Referer: https://94.23.2.138:2222/CMD_SKINS
7: Sec-Fetch-Mode: navigate
8: Sec-Fetch-Site: same-origin
9: Sec-Fetch-User: ?1
10: Upgrade-Insecure-Requests: 1
11: User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/77.0.3865.90 Safari/537.36
Checking referer https://94.23.2.138:2222/CMD_SKINS to 94.23.2.138:2222
Referer check passed: 94.23.2.138=94.23.2.138 2222=2222
Sockets::handshake - end
Plugin::addHooks: start
Plugin::addHooks: end
Command::run: finished /HTM_INDEX_RESELLER
/CSS_STYLE
GET string: v=1.52.1&tokenize_css=yes
0: Accept-Encoding: gzip, deflate, br
1: Accept-Language: pt-BR,pt;q=0.9,en-US;q=0.8,en;q=0.7,fr;q=0.6,es;q=0.5,la;q=0.4
2: Accept: text/css,*/*;q=0.1
3: Connection: keep-alive
4: Cookie: mp_f48baf7f57bdb924fc68a786600d844e_mixpanel=%7B%22distinct_id%22%3A%20%22f7282cf462d4bf2849ed651ca8513a12%22%2C%22%24device_id%22%3A%20%2216ccfd5a8f4302-0e01267a6c396e-38637701-13c680-16ccfd5a8f57ab%22%2C%22%24user_id%22%3A%20%22f7282cf462d4bf2849ed651ca8513a12%22%2C%22%24initial_referrer%22%3A%20%22https%3A%2F%2F94.23.2.138%2F~nadiadra%2Fwp-admin%2Fplugins.php%3Fplugin_status%3Dall%26paged%3D1%26s%22%2C%22%24initial_referring_domain%22%3A%20%2294.23.2.138%22%7D; wpglobus-language-old=en; wpglobus-language=en; session=w4gQyJkj2RMA03PgfiZQNrjDfSZd8mj2qOSmhBWjcsrbvEFYwowIfgVJ85wFpdHd
5: Host: 94.23.2.138:2222
6: Referer: https://94.23.2.138:2222/HTM_INDEX_RESELLER
7: Sec-Fetch-Mode: no-cors
8: Sec-Fetch-Site: same-origin
9: User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/77.0.3865.90 Safari/537.36
Checking referer https://94.23.2.138:2222/HTM_INDEX_RESELLER to 94.23.2.138:2222
Referer check passed: 94.23.2.138=94.23.2.138 2222=2222
Plugin::addHooks: start
Plugin::addHooks: end
Command::run: finished /CSS_STYLE
Sockets::handshake - begin
Sockets::handshake - begin
 

Ana Carolina

Verified User
Joined
May 3, 2018
Messages
18
I updated the DA sucessfuly. Now the revolution skin work. Updated the DKIM code, lets see if it worked.
 
Top