Dovecot down error

alexismya2

Verified User
Joined
Aug 13, 2008
Messages
56
I hired a system administrator update my CustomBuild versions.txt file. Immediately when he ran the update I received an email "New Message: The service 'dovecot' on server server.xxxxx.com is currently down". (The xxxxx was my server name.)

I get this message every hour on the hour.

How can I fix dovecot so I don't get these down email warnings?
 
Last edited:

BBM

Verified User
Joined
Jun 8, 2013
Messages
332
Location
Dutch Mountains
You need to show what errors are found in the logs as to why Dovecot is stopped.

But why doesn't your System Admin fix it?
Or simply restore the backup he (should've) took right before the update.
 

alexismya2

Verified User
Joined
Aug 13, 2008
Messages
56
He cannot fix this. This is why I am in the forums. If you tell me which logs to pull I can post the results here.

I use Google apps for my email. It's installed in my server. Do I need dovecot active?
 

alexismya2

Verified User
Joined
Aug 13, 2008
Messages
56
[root@server /home/admin]# service dovecot start
Starting dovecot: [ OK ]
[root@server /home/admin]# doveconf: Fatal: Error in configuration file /etc/dovecot/dovecot.conf line 18: Unknown setting: username_filter
 

Awd

Verified User
Joined
Aug 9, 2015
Messages
316
Did you try to rebuild dovecot already?
Code:
cd /usr/local/directadmin/custombuild
./build update
./build dovecot
 

alexismya2

Verified User
Joined
Aug 13, 2008
Messages
56
Could this rebuild cause any server problems? I am not experienced enough to fix problems if they occur.
 

alexismya2

Verified User
Joined
Aug 13, 2008
Messages
56
Yes, I did the rebuild and had the same message. Fatal: Error in configuration file /etc/dovecot/dovecot.conf line 18: Unknown setting: username_filter

In my dovecot.conf file this is what I see:

[root@server /etc]# cat dovecot.conf
#0.2
## Dovecot 2.0 configuration file

!include conf/ip.conf

auth_username_chars = abcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZ01234567890.-_@&
auth_verbose = yes
disable_plaintext_auth = no
login_greeting = Dovecot DA ready.
mail_access_groups = mail
default_login_user = dovecot
mail_location = maildir:~/Maildir

!include conf/limits.conf
!include conf/maildir_copy_with_hardlinks.conf

passdb {
username_filter = !*@*
driver = passwd
}

passdb {
username_filter = *@*
args = username_format=%n /etc/virtual/%d/passwd
driver = passwd-file
}

!include conf/protocols.conf
!include conf/mail_plugins.conf

service auth {
user = root
}
service imap-login {
process_min_avail = 16
user = dovecot
}
service pop3-login {
process_min_avail = 16
user = dovecot
}

!include conf/ssl.conf

userdb {
driver = passwd
}

userdb {
args = username_format=%n /etc/virtual/%d/passwd
driver = passwd-file
}

verbose_proctitle = yes

protocol imap {
!include conf/imap_mail_plugins.conf
}

protocol pop3 {
pop3_uidl_format = %08Xu%08Xv
pop3_logout_format = top=%t/%p, retr=%r/%b, del=%d/%m, size=%s, bytes=%i/%o
}

!include conf/mail_max_userip_connections.conf

!include_try conf/lmtp.conf

!include conf.d/*.conf
[root@server /etc]
 

alexismya2

Verified User
Joined
Aug 13, 2008
Messages
56
Can you look at the character line in the dovecot.conf file? It shows acceptable characters
auth_username_chars = abcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZ01234567890.-_@&

Why then do I see an ! in the username_filter field? Is this the error? I removed the ! and then ran service dovecot start and the same fatal error came up about line 18.
 
Last edited:

alexismya2

Verified User
Joined
Aug 13, 2008
Messages
56
Do you have dovecot_conf enabled in options.conf (/usr/local/directadmin/custombuild )?
When I get to that file how will I know if it is enabled or not? Will it say yes or no or y or n? I apologize if my questions seem silly but I'm learning. I really wish that I could get someone who would answer my questions quickly rather than me waiting hours and hours and hours. I thought that this group was here to help people.
 
Last edited:

Awd

Verified User
Joined
Aug 9, 2015
Messages
316
I really wish that I could get someone who would answer my questions quickly rather than me waiting hours and hours and hours. I thought that this group was here to help people.
You will not get far with that attitude. If you want to be helped immediately you need to hire a server admin.

That being said, look something simular like this in oprions.conf
Code:
#Mail Settings 
exim=no 
eximconf=no 
eximconf_release=4.5 
blockcracking=no 
easy_spam_fighter=no 
spamd=no 
sa_update=daily 
dovecot=yes 
[B]dovecot_conf=yes [/B]
pigeonhole=no
dovecot_conf=yes means that you enabled dovecot.conf
 

alexismya2

Verified User
Joined
Aug 13, 2008
Messages
56
Thank you for your assistance. I've been coming to this forum for many years. I don't have an attitude. I am asking for help. I want to learn. I really miss my friend Jeff Lasman who was always kind and helpful in this forum.
 
Last edited:

zEitEr

Super Moderator
Joined
Apr 11, 2005
Messages
13,900
Location
GMT +7.00
By the way Dovecot older than 2.3.0 will fail with dovecot.conf 0.3, so if you keep Dovecot 2.2.33 in order to avoid issues with duplicates and crashes you will have issues with dovecot.conf 0.3, so either do not upgrade:

Code:
dovecot.conf 0.2 to 0.3 update is available.
or prepare to correct /etc/dovecot/conf/ssl.conf
 
Top