Email does not arrive. Trying to place it in non-existant location.

jmstacey

Verified User
Joined
Feb 12, 2004
Messages
4,107
Location
Colorado
Outgoing email works fine, but incoming doesn't. When I try to send a email to an account on one of my subdomains I don't get a bounce or anything but when I try to send to my root domain, it bouces back with the wrong location.

admin@server.jmstacey.net
(ultimately generated from admin@jmstacey.net)
failed to stat /etc/virtual/server.jmstacey.net/. (No such file or
directory):
retry timeout exceeded

I checked that directory out and it should be /etc/virtual/jmstacey.net

server.jmstacey.net is the hostname of the server (should I change it to my root domain even though I was told not to?)

In the domainowners file in the /etc/virtual/ directory it has it listed correctly I think (jmstacey.net: admin)
And in the domains file it has server.jmstacey.net at the top and then my root domain further down in the list.

Should that hostame not be in there?

Thanks for the help
 

DirectAdmin Support

Administrator
Staff member
Joined
Feb 27, 2003
Messages
9,050
Hello,

The hostname directory needs to exist, but should be empty. Just create /etc/virtual/server.jmstacey.net and chown it to mail:mail, 600. Make sure that server.jmstacey.net is in the /etc/virtual/domains file, and *not* in the /etc/virtual/domainowners file.

John
 

jmstacey

Verified User
Joined
Feb 12, 2004
Messages
4,107
Location
Colorado
But server.jmstacey.net is the hostname of my computer so it technically shouldn't exit..

One other thing, it worked a while back when I used a 3rd party dns manager and pointed the mx record to my server so.. :confused:
 

jmstacey

Verified User
Joined
Feb 12, 2004
Messages
4,107
Location
Colorado
Anyways, I did as you said and it worked almost, just had to edit some preferences so it wouldn't say my email address was @server.jmstacey.net even though it still worked.

One more thing though. Am I going to recieve ALL cron email errors from all accounts? or all my subdomains? If so, how do I disable it from sending emails as default from my own cron jobs instead of having to do the null >.... in the job?

Thanks
 

DirectAdmin Support

Administrator
Staff member
Joined
Feb 27, 2003
Messages
9,050
You could just run this:

crontab -u username -e

and add:
MAILTO=""

to the top of the cronjob. This will tell cron not to email anything. Note that when you make a change to your cron through DA, it will be overwritten.

John
 
Top