Error After Updating DirectAdmin

+++

Verified User
Joined
Oct 1, 2006
Messages
8
Location
Sacramento, CA
I have been successfully running DirectAdmin for a few months now on this install. Today I updated DA via my admin control panel. I tried to refresh the page to continue on with my operations and the page would not load (Unable to connect).

I entered into shell and started investigating.

I tried restarting directadmin:

center# ./directadmin start Starting DirectAdmin: [ OK ]
/usr/local/directadmin/directadmin: error while loading shared libraries: /usr/lib/libssl.so.4: ELF file OS ABI invalid
center# uname -a FreeBSD center.ojoink.com 6.3-PRERELEASE FreeBSD 6.3-PRERELEASE #0: Mon Nov 19 23:31:17 PST 2007 :/usr/obj/usr/src/sys/GENERIC i386

That didn't work... let's investigate more..

here is directadmin's system.log:

2007:12:27-12:43:09: Update of software successfull!
2007:12:27-12:43:10: signal TERM received. Waiting for children to exit
2007:12:27-12:43:10: Clean shutdown successful
2007:12:27-12:43:11: directadmin restarted
2007:12:27-12:43:11: directadmin started

Of course, directadmin is not running because it won't start (see above).

That's about all the info I have. DA has been working fine until this latest update. =(

Do you have any information that might help me?

+++
 

DirectAdmin Support

Administrator
Staff member
Joined
Feb 27, 2003
Messages
8,990
Hello,

I believe I've replied to the email you've already sent us, but for anyone else, if you see that, it's usually caused by an incorrect OS set in the license file. Email us your License ID and the OS you're using and we'll make sure it's set correctly.

Once the license is set correctly (you can check from your /clients account on our website), then update the binaries:
http://help.directadmin.com/item.php?id=29

John
 
Top