Error Mysql Please HELP

Cad0s

Verified User
Joined
May 6, 2012
Messages
10
Hi I try.

You cannot install MySQL, because you do not have it set in options.conf file.
#PHP Settings
php1_release=5.6
php1_mode=php-fpm
php2_release=no
php2_mode=php-fpm
opcache=no
htscanner=no
php_ini=no
php_timezone=America/New_York
php_ini_type=production
ioncube=no
zend=no
suhosin=no
x_mail_header=yes

#MySQL Settings
mysql=5.6
mariadb=10.0
mysql_inst=no
mysql_backup=yes
mysql_backup_gzip=no
mysql_backup_dir=/usr/local/directadmin/custombuild/mysql_backups
mysql_force_compile=no

#WEB Server Settings
webserver=apache
litespeed_serialno=trial
modsecurity=no
modsecurity_ruleset=comodo
apache_ver=2.4
apache_mpm=auto
mod_ruid2=no
userdir_access=yes
harden_symlinks_patch=yes
use_hostname_for_alias=no
redirect_host=server
redirect_host_https=no

#WEB Applications Settings
phpmyadmin=yes
phpmyadmin_ver=4
squirrelmail=yes
roundcube=yes
webapps_inbox_prefix=no

#ClamAV-related Settings
clamav=no
clamav_exim=yes
modsecurity_uploadscan=no
proftpd_uploadscan=no
pureftpd_uploadscan=no
suhosin_php_uploadscan=no

#Mail Settings
exim=no
eximconf=no
eximconf_release=4.4
blockcracking=no
easy_spam_fighter=no
spamassassin=no
sa_update=daily
dovecot=yes
dovecot_conf=yes
pigeonhole=no

#FTP Settings
ftpd=pureftpd

#Statistics Settings
awstats=no
webalizer=yes

#CustomBuild Settings
custombuild=2.0
autover=no
bold=yes
clean=yes
cleanapache=yes
clean_old_tarballs=yes
clean_old_webapps=yes
downloadserver=files22.directadmin.com

#Cronjob Settings
cron=no
cron_frequency=weekly
email=email@domain.com
notifications=yes
da_autoupdate=no
updates=no
webapps_updates=yes

#CloudLinux Settings
cloudlinux=no
cagefs=no

#Advanced Settings
autoconf=yes
automake=yes
libtool=yes
curl=yes
new_pcre=no


root@server:/usr/local/directadmin/custombuild# mysql -V
mysql Ver 14.14 Distrib 5.5.52, for linux2.6 (x86_64) using readline 5.1


161007 21:55:26 mysqld_safe mysqld from pid file /usr/local/mysql/data/server.pid ended
161007 21:55:45 mysqld_safe Starting mysqld daemon with databases from /usr/local/mysql/data
161007 21:55:45 [Note] /usr/local/mysql/bin/mysqld (mysqld 5.5.52) starting as process 18522 ...
161007 21:55:45 [Note] Plugin 'FEDERATED' is disabled.
161007 21:55:45 InnoDB: The InnoDB memory heap is disabled
161007 21:55:45 InnoDB: Mutexes and rw_locks use GCC atomic builtins
161007 21:55:45 InnoDB: Compressed tables use zlib 1.2.3
161007 21:55:45 InnoDB: Using Linux native AIO
161007 21:55:45 InnoDB: Initializing buffer pool, size = 128.0M
161007 21:55:45 InnoDB: Completed initialization of buffer pool
InnoDB: Error: space header page consists of zero bytes in data file ./ibdata1
161007 21:55:45 InnoDB: Could not open or create data files.
161007 21:55:45 InnoDB: If you tried to add new data files, and it failed here,
161007 21:55:45 InnoDB: you should now edit innodb_data_file_path in my.cnf back
161007 21:55:45 InnoDB: to what it was, and remove the new ibdata files InnoDB created
161007 21:55:45 InnoDB: in this failed attempt. InnoDB only wrote those files full of
161007 21:55:45 InnoDB: zeros, but did not yet use them in any way. But be careful: do not
161007 21:55:45 InnoDB: remove old data files which contain your precious data!
161007 21:55:45 [ERROR] Plugin 'InnoDB' init function returned error.
161007 21:55:45 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
161007 21:55:45 [ERROR] Unknown/unsupported storage engine: InnoDB
161007 21:55:45 [ERROR] Aborting

161007 21:55:45 [Note] /usr/local/mysql/bin/mysqld: Shutdown complete

161007 21:55:45 mysqld_safe mysqld from pid file /usr/local/mysql/data/server.pid ended
 
Last edited:
Top