Error on installation FreeBSD 7.2 64-bit

maiijarb

Verified User
Joined
Nov 8, 2006
Messages
57
Hi,

I am installing DA on FreeBSD 7.2 64-bit and get this error

PHP:
Options.conf has been installed successfully
beginning pre-checks, please wait...
adding gd ...
Fetching http://files.directadmin.com/services/packages-7.1-release/Latest/gd.tbz... Done.
pkg_add: package 'gd-2.0.35,1' or its older version already installed
rpm: not found
adding perl-DBI ...
Error: FTP Unable to get http://files.directadmin.com/services/packages-7.1-release/Latest/perl-DBI.tbz: Not Found
pkg_add: unable to fetch 'http://files.directadmin.com/services/packages-7.1-release/Latest/perl-DBI.tbz' by URL
https://www.directadmin.com/cgi-bin/daupdate?uid=0000&lid=00000: Unsupported scheme.
Cannot find the DirectAdmin binary.  Extraction failed

If you see an error that says to add --no-check-certificate, recompile wget:
http://help.directadmin.com/item.php?id=119
Thanks in advance
 

erohits

Verified User
Joined
Jun 26, 2009
Messages
28
i had the same error, but reinstalled freebsd

installed no other software

did a fetch ******/setup.sh of the install file

run it

then only fixed a error (no group admin)

then installed zend

and worked like a speedboot
 

DirectAdmin Support

Administrator
Staff member
Joined
Feb 27, 2003
Messages
8,923
The above perl-DBI wasn't supposed to be run for FreeBSD, it was added before FreeBSD was added. I've just found this thread so I simply changed:
Code:
if [ $B64 -eq 1 ]; then
to
Code:
if [ $B64 -eq 1 ] && [ -e /etc/redhat-release ]; then
since it only applies to the CentOS 64 systems.

As for the error, yes, at this time, recompile wget to support https, which isn't a supported "scheme" in the wget that generated the above output.
http://help.directadmin.com/item.php?id=119

John
 
Top