Evolution ignores custom domain variable's accessibility options

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
8,347
Location
LT, EU
Please try the following to fix it:
Code:
cd /usr/local/directadmin/data/skins
mkdir -p evolution
cd evolution
wget -O evolution.tar.gz https://demo.directadmin.com/download/evolution.tar.gz
tar xvzf evolution.tar.gz
cd ..
chown -R diradmin:diradmin evolution
Thank you for the report!
 

Canary

Verified User
Joined
Jun 26, 2015
Messages
14
I don't see any changes. hidden/api_only variables still show up like regular variables in both Modify domain and Create domain.

Installed skin:

Code:
version=0cd869ccd1ef3ff4e2d68069aac818a6ca440c44
I also found another problem. For listbox items in Modify domain, instead of the value saved in domain.conf for the variable, always the first item in the drop down list is selected.

For example for the variable

Code:
phpversion=type=listbox&item1txt=Account's Default (Unknown)&item1val=10&item2txt=PHP 5.6&item2val=56&item3txt=PHP 7.0&item3val=70&item4txt=PHP 7.1&item4val=71&item5txt=PHP 7.2&item5val=72&item6txt=PHP 7.3&item6val=73&string=PHP Version&default=10&desc=
I have the value phpversion=56 in

/usr/local/directadmin/data/users/USER/domains/DOMAIN.conf

But when I open Modify DOMAIN, Instead of PHP 5.6, PHP Version shows the value Account's Default.

Thanks
 

Canary

Verified User
Joined
Jun 26, 2015
Messages
14
Both issues seems to be fixed. There is only a minor issue left. I can't find variable descriptions. Are they available as tool-tips?

Thanks
 
Last edited:

Canary

Verified User
Joined
Jun 26, 2015
Messages
14
Just upgraded to the latest version but I don't see variable descriptions.

Skin version:

Code:
7c6786168bf084e7e7678e5bfd9d80920d134b8b
Thanks
 
Last edited:

Canary

Verified User
Joined
Jun 26, 2015
Messages
14
I just found another issue. When adding a new domain, Evolution embed api_only and hidden variables in the request. For example with a custom variable like this:

Code:
my_custom_var=type=checkbox&string=My Custom Variable&[B]checked=yes&desc=&api_only=yes&hidden=yes[/B]
When adding a new domain, evolution sends my_custom_var=no which is the wrong value. Enhanced skin does not have this problem because it ignores api_only and hidden variables when sending the request. The correct behaviour for Evolution should be not to embed api_only/hidden variables in the constructed request payload when adding a new domain. This way DirectAdmin will automatically use the default values for these variables.
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
8,347
Location
LT, EU
May you try latest version of the skin? Thank you!

Code:
cd /usr/local/directadmin/data/skins
mkdir -p evolution
cd evolution
wget -O evolution.tar.gz https://demo.directadmin.com/download/evolution.tar.gz
tar xvzf evolution.tar.gz
cd ..
chown -R diradmin:diradmin evolution
 
Top