Exim 4.94 update causes email temporary rejects

PurpleAlien

New member
Joined
Jun 21, 2020
Messages
11
Hi,

I've just run an update on directadmin which also upgraded Exim to 4.94.
In the exim mainlog I'm seeing the following for all incoming mails:

temporarily rejected RCPT <xxxxx@yyyyy>: failed to expand "${if exists{/etc/virtual/${domain}/aliases}{${lookup{$local_part}lsearch{/etc/virtual/${domain}/aliases}}}}": NULL

In /var/log/exim/paniclog I have these for each domain:

Tainted filename for search: '/etc/virtual/yyyy/aliases'

I've rerun ./build exim and ./build exim_conf and also ./build rewrite_confs but the issue remains. There were no issues with the previous version.


Any ideas?
 

PurpleAlien

New member
Joined
Jun 21, 2020
Messages
11
Yes. Otherwise I would not have had the new version of Exim. Ran it several times since as well, just in case.
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
9,305
Location
LT, EU
Yes. Otherwise I would not have had the new version of Exim. Ran it several times since as well, just in case.
Any custom code in exim configuration? I don’t recall seeing anything like this with newest versions. If the license has support included - you may open a DA ticket with access to the system.
 

PurpleAlien

New member
Joined
Jun 21, 2020
Messages
11
No, no custom code. Falling back to 4.93 and everything is fine again. I'll check the support...
 

Imtek

Verified User
Joined
Dec 11, 2005
Messages
157
Location
The Netherlands
Got the same, Tainted filename for search: '/etc/virtual/yyyy/aliases' but only on servers with MagicSpam includes it looks like.
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
9,305
Location
LT, EU
Got the same, Tainted filename for search: '/etc/virtual/yyyy/aliases' but only on servers with MagicSpam includes it looks like.
I guess they might not be compatible with exim 4.94 then :)
 

joshuasan

New member
Joined
Jun 21, 2020
Messages
3
Same Issue here
" Tainted filename for search: '/etc/virtual/mydomain.com/majordomo/list.aliases' "

any update on this ?
 

joshuasan

New member
Joined
Jun 21, 2020
Messages
3
I solved my problem with started again with these this time use build set_fastest. and it solved.
build says yellow OK when he can not connect "A" server but he

cd /usr/local/directadmin/custombuild
./build set_fastest
./build update
./build set exim yes
./build set eximconf yes
./build set eximconf_release 4.5
./build set spamassassin yes
./build update
./build exim
./build exim_conf
 

PurpleAlien

New member
Joined
Jun 21, 2020
Messages
11
Yes, that might be it. It's on Debian 8 LTS (which is supported until the end of the month). We did not update directadmin on the replacement for this one yet because this issue popped up. I didn't think this would be related, and the relevant config comes in through directadmin.
 
Top