Exim does not deliver local e-mail since upgrade to 4.93.0.4 ?

ngj

New member
Joined
Feb 22, 2020
Messages
3
Hello,

I use custombuild 2.0.0 (rev: 2410). Yesterday evening, I performed a custombuild update / versions / update_versions. This has upgraded, among others, Exim (to version 4.93.0.4). When reviewing my logs today, I notice that there is a buildup of frozen e-mails in the Exim queue.

When I look at a particular e-mail in the queue using exigrep -I -l 1j5RcA-0006LC-LI /var/log/exim/mainlog, I see:
2020-02-22 10:02:26 1j5RcA-0006LC-LI lowest numbered MX record points to local host: mydomain.com

Where "mydomain.com" is one of my own domain names, for which a DirectAdmin user has been created on this system. Until yesterday, mail for this domain was correctly delivered by Exim to the local system (i.e., I received it in the mailbox I have on that system, and which I can access using IMAP). Since the upgrade of Exim, these e-mails no longer seem to be delivered.

There exists a directory /etc/virtual/mydomain.com, and "mydomain.com" is still listed in the /etc/virtual/domains file. (Nor did I change anything else to the respective DirectAdmin user.)

In my old exim.conf file, which seems to have been renamed to /etc/exim.conf.old, there is a line as follows:
domainlist local_domains = lsearch;/etc/virtual/domains
In my new /etc/exim.conf file, this seems to have changed to the following:
domainlist local_domains = @
I suspect this may have something to do with my problem?

Does anyone have any suggestions as to how I can get Exim to deliver e-mail to my local domains again, preferably in a way that would be robust against future upgrades of Exim using custombuild? Any help would be greatly appreciated.

Best regards,
Niels
 

ngj

New member
Joined
Feb 22, 2020
Messages
3
PS: I use Dovecot as my IMAP server.

In the /usr/local/directadmin/custombuild/options.conf file, the following mail settings are configured:

#Mail Settings
exim=yes
eximconf=no
eximconf_release=4.4
blockcracking=no
easy_spam_fighter=no
spamd=no
sa_update=daily
dovecot=yes
dovecot_conf=yes
pigeonhole=no


I suspect I may need to enable eximconf in order to get a "good" exim.conf file? Which release should I use ideally?
 

ditto

Verified User
Joined
Apr 27, 2009
Messages
2,565
You should always use the newest release of both exim.conf and exim. Yes, you should change eximconf=no to become eximconf=yes, then do this:

Code:
cd /usr/lcoal/directadmin/custombuild
./build update
./build exim_conf
./build exim
 
  • Like
Reactions: ngj

ngj

New member
Joined
Feb 22, 2020
Messages
3
Perfect; this seems to work. Thanks a lot!

PS: I have set the eximconf_release option to 4.5 before building exim_conf.
 

ditto

Verified User
Joined
Apr 27, 2009
Messages
2,565
That sounds good. :) I also has eximconf_release=4.5, that would be the newest.
 
Top