forwarding (SPF error?) and Return-Receipt bounce issue

Tootle

Verified User
Joined
Sep 1, 2011
Messages
38
Hi, I'm trying to find solution but I must ask you guys for help.

Code:
 forwardtest456@wp.pl
    (ultimately generated from forwardtest456@duan.pl)
    SMTP error from remote mail server after MAIL FROM:<forwardtest456@gmail.com> SIZE=3006:
    host mx.wp.pl [212.77.101.4]: 550 SPF Error:
    Received-SPF: neutral (smtp.wp.pl: 188.116.4.48 is neither permitted nor denied by domain of gmail.com) client-ip=188.116.4.48; envelope-from=forwardtest456@gmail.com;
#1 : In this scenario I'm creating a mail from forwardtest456@gmail.com --TO--> forwardtest456@duan.pl [domain set on DA box on its 2nd IP 188.116.52.25] (which also forwards to forwardtest456@wp.pl [external mail] ]) and that forwarding ends with aforementioned bounced error message ( 188.116.4.48 is a main IP of DA box)

from domain dns administration
Code:
duan.pl.	TXT	"v=spf1 a mx ip4:188.116.4.48 ~all"
what is more

#2 users mails with Return-Receipt flag bounces to admin account on the box with [Delayed Bounce]?? Is that because of when /etc/virtual/limit_unknown reaches it's max?

Any chances to help figure it out that bounce-mess :) ? Big thanks in advance.

using SpamBlockerTechnology* powered exim.conf, Version 4.1
my exim.conf
 
Last edited:

scsi

Verified User
Joined
Aug 19, 2008
Messages
4,695
The spf ip needs to be the ip of the mail server that the mail comes from.
 

Tootle

Verified User
Joined
Sep 1, 2011
Messages
38
Thanks. That's OK.
Problem is when any of my users comopse a message via Roundcube with return-receipt flag. The coming back info from receipient is blocked

exim/mainlog
Code:
cancelled by system filter: Delayed bounce message ignored
I believe thats because of
part of etc/system_filter.exim
Code:
if $sender_address is ""
then
     if ${lookup{${extract{2}{@}{$recipients}}}lsearch{/etc/virtual/domains}{yes}{no}} is "no"
     then
         headers add "Old-Subject: $h_subject:"
         headers remove "Subject"
         headers add "Subject: [Delayed Bounce]$h_old-subject:"
         headers remove "Old-Subject"
         deliver "admin@mydomain.com"

         noerror fail text "Delayed bounce message ignored"
         seen finish
     endif
endif
if not first_delivery
then
  finish
endif
Thanks for any ideas how to correct that behaviour.
 
Top