Frontpage problems at FreeBSD 5.x?

wdv

Verified User
Joined
Oct 22, 2003
Messages
163
Hey,

I discovered that frontpage isn't working in FreeBSD 5.x:

su-2.05b# /usr/local/frontpage/version5.0/bin/owsadm.exe
/usr/libexec/ld-elf.so.1: /usr/lib/libc_r.so.4: Undefined symbol "_flockfile"

I did install the 4.x compatibility package.

Any idea what's wrong?
 

wdv

Verified User
Joined
Oct 22, 2003
Messages
163
I found the solution:

Symlink /usr/lib/libc_r.so.4 to /usr/local/lib/compat/libc_r.so.4.compat4x and it works :)
 

nobaloney

NoBaloney Internet Svcs - In Memoriam †
Joined
Jun 16, 2003
Messages
26,119
Location
California
Great job, wdv.

Can you post this as a mini how-to in the how-to section?

Thanks.

Jeff
 

dan35

Verified User
Joined
Nov 21, 2004
Messages
123
Hi,

There isn't any libc_r.so.4.compat4x on Freebsd 5.3.

Thanks!
 

dan35

Verified User
Joined
Nov 21, 2004
Messages
123
Hi,

I don't know how to fix this:



log:

[error] [client myip xxx] (13)Permission denied: getgrgid: invalid groupid 1015
[Mon Jan 10 02:47:36 2005] [error] (13)Permission denied: exec of /usr/local/frontpage/version5.0/apache-fp/_vti_bin/fpexe failed
[Mon Jan 10 02:47:36 2005] [error] [client ip xx] Premature end of script headers: /usr/local/frontpage/version5.0/apache-fp/_vti_bin/fpexe


/etc/group
....
myname:*:1015:


#cd /usr/local/frontpage/version5.0/apache-fp/_vti_bin/
#ls -l
total 12
-rwsr-xr-x 1 root bin 11451 Jun 27 2003 fpexe

I can't connect to my site via frontpage.
 
Last edited:

dan35

Verified User
Joined
Nov 21, 2004
Messages
123
Damn! Stupid mistake!

just chmod 644 group (the old was 640)
 
Last edited:
Top