How do I control PHP version for email pipe?

ceromus

New member
Joined
Oct 30, 2019
Messages
3
I am getting this message: PHP Fatal error: The file /home/username/domains/domain.com/public_html/billing/pipe/pipe.php was encoded by the ionCube Encoder for PHP 5.0 and cannot run under PHP 7.1 or later.
Please ask the provider of the script to provide a version encoded with the ionCube Encoder for PHP 7.1. in Unknown on line 0

but that domain is set to php 5.6, so why is it still trying to use php 7? how can I resolve this?
 

ceromus

New member
Joined
Oct 30, 2019
Messages
3
Oh nevermind got it, i specify the version in the pipe forward:
"| /usr/local/php56/bin/php -q /home/username/domains/domain.com/public_html/billing/pipe/pipe.php"
 

ginokiptoli

New member
Joined
Nov 26, 2019
Messages
6
I am getting this message: PHP Fatal error: The file /home/username/domains/domain.com/public_html/billing/pipe/pipe.php was encoded by the ionCube Encoder for PHP 5.0 and cannot run under PHP 7.1 or later.
Please ask the provider of the script to provide a version encoded with the ionCube Encoder for PHP 7.1. in Unknown on line 0

but that domain is set to php 5.6, so why is it still trying to use php 7? how can I resolve this?
Oh nevermind got it, i specify the version in the pipe forward:
 

ginokiptoli

New member
Joined
Nov 26, 2019
Messages
6
Oh nevermind got it, i specify the version in the pipe forward usa today protonmail :
"| /usr/local/php56/bin/php -q /home/username/domains/domain.com/public_html/billing/pipe/pipe.php"
Make sure file hesk_pipe.php is executable (CHMOD to 755 (rwxr-xr-x).
Make sure email piping is enabled in your HESK settings.
Try enabling debug mode in your HESK settings and see if you at least get a returned mail then.
 
Top