How i can install php-devel 5.3.8?

nikohal

Verified User
Joined
Dec 12, 2011
Messages
37
Hi,
I use centos 6.0 and directadmin 1.39. Yesterday i upgrade php to 5.3.8, but I need php-devel 5.3.8, where i can find that package?

Regards, Niko H.
 

scsi

Verified User
Joined
Aug 19, 2008
Messages
4,695
pear is included with php that is installed from custombuild...how is it different?
 

nikohal

Verified User
Joined
Dec 12, 2011
Messages
37
Sorry, my mistake, not pear. I mean pecl
I get error when I install pecl package

pecl install fileinfo
WARNING: "pear/Fileinfo" is deprecated in favor of "channel://php-src/ext/fileinfo/in php sources"
downloading Fileinfo-1.0.4.tgz ...
Starting to download Fileinfo-1.0.4.tgz (5,835 bytes)
.....done: 5,835 bytes
3 source files, building
running: phpize
Cannot find config.m4.
Make sure that you run '/usr/local/bin/phpize' in the top level source directory of the module

ERROR: `phpize' failed
 

zEitEr

Super Moderator
Joined
Apr 11, 2005
Messages
14,243
Location
GMT +7.00
Try then

Code:
cd /usr/local/src/
pecl download fileinfo
tar -zxvf Fileinfo-1.0.4.tgz
cd Fileinfo-1.0.4
/usr/local/php5/bin/phpize
./configure --with-php-config=/usr/local/php5/bin/php-config
make && make install
and update your actual php.ini to load extension fileinfo.so
 

nikohal

Verified User
Joined
Dec 12, 2011
Messages
37
I get error:

cd /usr/local/php5/bin/phpize
-bash: cd: /usr/local/php5/bin/phpize: No such file or directory

What to do?

Regards,

Niko H.
 

zEitEr

Super Moderator
Joined
Apr 11, 2005
Messages
14,243
Location
GMT +7.00
/usr/local/php5/bin/phpize is supposed to be a bin-file, you can not cd to it.

If you have neither file /usr/local/php5/bin/phpize nor directory /usr/local/php5/

run this instead

Code:
cd /usr/local/src/
pecl download fileinfo
tar -zxvf Fileinfo-1.0.4.tgz
cd Fileinfo-1.0.4
/usr/local/bin/phpize
./configure --with-php-config=/usr/local/bin/php-config
make && make install
 

nikohal

Verified User
Joined
Dec 12, 2011
Messages
37
I get follow error, I thik I need php-devel?

/usr/local/php5/bin/phpize
-bash: /usr/local/php5/bin/phpize: No such file or directory

Regards,

Niko H.
 

nikohal

Verified User
Joined
Dec 12, 2011
Messages
37
checking for magic files in default path... not found
configure: error: Please reinstall the libmagic distribution

but I install file-devel, and error is resolved :)

thanks
 

NaveenRahul

New member
Joined
Oct 31, 2013
Messages
1
issue with installing php-devel

im tring todo the same but im trying to install php-devel,which require to add apd ie

pecl install apd


i try to following the same installation and but not working this is what i get exatcly

downloading apd-1.0.1.tgz ...
Starting to download apd-1.0.1.tgz (36,643 bytes)
..........done: 36,643 bytes
File /usr/local/src/apd-1.0.1.tgz downloaded
[root@srmerpsrv src]# tar -zxvf apd-1.0.1.tgz
package.xml
apd-1.0.1/LICENSE
apd-1.0.1/Makefile.in
apd-1.0.1/README
apd-1.0.1/apd.dsp
apd-1.0.1/apd_array.c
apd-1.0.1/apd_array.h
apd-1.0.1/apd_lib.c
apd-1.0.1/apd_lib.h
apd-1.0.1/apd_summary.c
apd-1.0.1/build
apd-1.0.1/build/CVS
apd-1.0.1/build/CVS/Entries
apd-1.0.1/build/CVS/Repository
apd-1.0.1/build/CVS/Root
apd-1.0.1/build/mkdep.awk
apd-1.0.1/build/scan_makefile_in.awk
apd-1.0.1/build/shtool
apd-1.0.1/config.m4
apd-1.0.1/php_apd.c
apd-1.0.1/php_apd.h
apd-1.0.1/php_sockets.h
apd-1.0.1/php_sockets_win.h
apd-1.0.1/pprofp
apd-1.0.1/pprof2calltree
apd-1.0.1/win32compat.c
apd-1.0.1/win32compat.h
[root@srmerpsrv src]# cd apd-1.0.1
[root@srmerpsrv apd-1.0.1]# /usr/bin/phpize
Can't find PHP headers in /usr/include/php
The php-devel package is required for use of this command.
[root@srmerpsrv apd-1.0.1]# ./configure --with-php-config=/usr/bin/php-config
-bash: ./configure: No such file or directory
[root@srmerpsrv apd-1.0.1]# make && make install



any idea ??

what im missing
 
Top