How to increase Wordpress upload limit

sakibjames

New member
Joined
Dec 23, 2019
Messages
6
Hello
I tried all the method like
i) Create php.ini file in public_html and wp-admin folder. but is not working.
ii) i change the wp-config and add this line "define( 'WP_MEMORY_LIMIT', '128M' );" is not work.
iii) .htaccess when i tried to change this file then show me -
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator at webmaster@ecglobalconnect.com to inform them of the time this error occurred, and the actions you performed just before this error.
More information about this error may be available in the server error log.
iv) Direct Admin panel > Extra Features > Select PHP version > PHP Selector | Options i change here. but is not work.

How i fix this problem. how I can upload direct from wordpress dashboard.
 

Zhenyapan

Verified User
Joined
Feb 23, 2018
Messages
123
Location
UA
Via directadmin filemanager in public_html of your domain create file test.php (or any another name) with code inside it:
<?php phpinfo(); ?>
then open it in browser yourdomain.com/test.php
and check for string ""Loaded Configuration File"
then just change "post_max_size" and "upload_max_filesize" in this file
then restart Apache (if CLI_PHP used)
or restart apropriate php_fpm daemon in directadmin-services on Admin Level / or via SSH_console
sometimes you will need to modify client_max_body_size in NGINX too, if files larger than configured limit
WP_MEMORY_LIMIT - analog of memory_limit in PHP (RAM limit for scripts - not for uploaded files)
 
Top