How to install spamblocker?

asmar

Verified User
Joined
Aug 29, 2005
Messages
96
I've searched a lot on this forum but didn't find a guide how to install and configure spamblock.

I'm currently using the default directadmin installation with exim and spamassassin but got huge problem with zombies and server load coming from spamassassin.

Can anyone please post instructions how to enable/install spamblock?
 

icepick

Verified User
Joined
Aug 19, 2005
Messages
122
Location
Auckland, New Zealand
spamblocker come default with DA?

Hi,

Up till now I've assumed spamblocker was installed by default with DA and I still believe that, however all other instances of DA (we have nearly 20 instances) we've used MailScanner but are planning on running just stand alone DA boxes now. I noticed from a few searches that spamblocker came with ClamAV support, however I cannot find anywhere with instructions on getting this added to DA Spamblocker, can someone point me in the right direction please.

Thanks
Barry
 

nobaloney

NoBaloney Internet Svcs - In Memoriam †
Joined
Jun 16, 2003
Messages
26,119
Location
California
Only the latest version of SpamBlocker can manage ClamAV. To use it with older versions you'll have to manage it yourself.

SpamBlocker exim.conf file is never usable without some (simple) modfications to the file.

And of course if you want a domain to use the SpamBlocker blocklists you have to add the domain name to the /etc/virtual/use_rbl_domains file.

The latest version of SpamBlocker (the one that can be used with ClamAV) may be found at my website at http://www.nobaloney.net/downloads/

Jeff
 

ericovk

Verified User
Joined
Apr 17, 2012
Messages
219
Location
Rotterdam, Netherlands
I know this thread is super old, but I am a little stuck here. I tried to install SpamBlocker, but I can't figure out if it's running. I'm still receiving a lot of spam, so guess it's not running.
I tried installing SB via smtalk's link. (http://help.directadmin.com/item.php?id=51). Via that manual I "installed" SpamBlocker.exim.conf.2.1.1-release as I can read in the exim.conf. I can't figure out what to do next??
 

Richard G

Verified User
Joined
Jul 6, 2008
Messages
4,218
Location
Maastricht
That's what you get when following very old threads.:)

If you followed that link to the help section of directadmin, you did not install spamblocker. you only installed a newer exim.pl and maybe a dovecot patch.
I suggest you follow the spamblocker 4 thread and especially the link to the Nobaloney website mentioned in the first post, which contains a complete documentation about how to install spamblocker.
 

nobaloney

NoBaloney Internet Svcs - In Memoriam †
Joined
Jun 16, 2003
Messages
26,119
Location
California
Tomorrow I'm going to issue a quickfix to get rid of the NJABL blocklist, which is no longer active. So if you've installed SpamBlocker 4 you should comment out the NJABL line and restart exim.

Jeff
 
Top