httpd failes to start after upgrading to 2.2.3

zurih

Verified User
Joined
Jun 26, 2006
Messages
23
Hi

I upgraded apache from 2.0.59 to 2.2.3 and it failes to start after that.

I recieve the error:
Starting httpd: httpd: Syntax error on line 67 of /etc/httpd/conf/httpd.conf: Cannot load /usr/lib/apache/mod_frontpage.so into sere
[FAILED]

when I comment
LoadModule frontpage_module /usr/lib/apache/mod_frontpage.so

the service starts fine. seems to be a problem with mod_frontpage.

When I do ./build mod_frontpage_ap2, I recieve lots of errors like:

/usr/local/frontpage/version5.0/apache2/mod_fpcgid.c:266: error: `AP_SIG_GRACEFUL' undeclared (first use in this function)
/usr/local/frontpage/version5.0/apache2/mod_fpcgid.c:266: error: (Each undeclared identifier is reported only once

Can anyone point out the problem?

Thanks
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
9,097
Location
LT, EU
Apache 2.2 does not support mod_frontpage.
 
Last edited:

zurih

Verified User
Joined
Jun 26, 2006
Messages
23
ohh. didnt knowed that.

anyway I dont need this mod, so I commented it in httpd.conf.

thanks anyway.
 

nobaloney

NoBaloney Internet Svcs - In Memoriam †
Joined
Jun 16, 2003
Messages
26,119
Location
California
Do you know where these patches come from?

Are they official?

Are they safe?

Jeff
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
9,097
Location
LT, EU
Yes, I do. They are not official, but safe :) Just a few patch files for Apache source and that's it.
 
Top