httpd-lsrecaptcha.conf settings not being applied

chwba

Verified User
Joined
Dec 23, 2019
Messages
25
Hello,

I have changed /usr/local/lsws/conf/httpd-lsrecaptcha.conf to the following content to activate reCAPTCHA. After I have restarted OLS gracefully.

Code:
lsrecaptcha  {
  enabled                      1
  siteKey                 6LfmisYUAAAAAOgLBe-xDvWPWgQooG3GLHCwVz
  secretKey               6LfmisYUAAAAAP9TRx6uOGrwZNuIoTQ_xAns
  type                            2
  maxTries                    3
  allowedRobotHits       3

  botWhiteList  {
  google.com
  }
  regConnLimit            15000
  sslConnLimit            10000
}
Yet the GUI does not display the changes as per the below screenshot, what am I missing?

 

chwba

Verified User
Joined
Dec 23, 2019
Messages
25
Figured out there is a filed called httpd_config.conf where all the config files are being "included", obviously httpd-lsrecaptcha.conf is commented out by default..
 

jayw1

Verified User
Joined
Nov 20, 2019
Messages
127
Location
USA
Figured out there is a filed called httpd_config.conf where all the config files are being "included", obviously httpd-lsrecaptcha.conf is commented out by default..
Thanks, I'm still trying to figure out where everything is as well. I'm used to the GUI.
Did you find how to create realms yet? I want to htpasswd protect directories and files.
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
8,539
Location
LT, EU
CB 2.0 rev. 2343 has it uncommented now :) They had issues with 1.5 at that time, and we reverted to 1.4 and commented line out (it was a leftover). Thank you for the report!
 
Top