Install issue, wepb/decode.h not found

Dustin_Van

New member
Joined
Dec 4, 2019
Messages
3
Hello,
Brand new Centos 7 server with Direct Admin installed.
After this server became needed I was finishing up some of the odds and ends, and installing CustomBuild 2.0. However when i run the build all command the first time it stops here.

Code:
Configuring extensions
checking for strings.h... (cached) yes
checking io.h usability... no
checking io.h presence... no
checking for io.h... no
checking for strtoll... yes
checking for atoll... yes
checking whether to enable LIBXML support... yes
checking libxml2 install dir... /usr/local/lib
checking for xml2-config path... /usr/local/bin/xml2-config
checking whether libxml build works... yes
checking for OpenSSL support... yes
checking for Kerberos support... yes
checking whether to use system default cipher list instead of hardcoded value... no
checking for krb5-config... /usr/bin/krb5-config
checking for RAND_egd... no
checking for pkg-config... /usr/bin/pkg-config
checking for PCRE headers location... /usr/local/include
checking for PCRE library location... /usr/local/lib
checking for pcre_jit_exec in -lpcre... yes
configure: WARNING: PHP is going to be linked with an external PCRE, --with-pcre-valgrind has no effect
checking whether to enable the SQLite3 extension... yes
checking bundled sqlite3 library... yes
checking for ZLIB support... yes
checking if the location of ZLIB install directory is defined... no
checking for zlib version >= 1.2.0.4... 1.2.7
checking for gzgets in -lz... yes
checking whether to enable bc style precision math functions... yes
checking for BZip2 support... no
checking whether to enable calendar conversion support... yes
checking whether to enable ctype functions... yes
checking for cURL support... yes
checking for libcurl.pc... using default path
checking for cURL 7.10.5 or greater... 7.29.0
checking for SSL support in libcurl... yes
checking how to run the C preprocessor... cc -E
checking for openssl support in libcurl... no
checking for gnutls support in libcurl... no
checking for curl_easy_perform in -lcurl... yes
checking for curl_easy_strerror in -lcurl... yes
checking for curl_multi_strerror in -lcurl... yes
checking for QDBM support... no
checking for GDBM support... no
checking for NDBM support... no
checking for TCADB support... no
checking for LMDB support... no
checking for Berkeley DB4 support... no
checking for Berkeley DB3 support... no
checking for Berkeley DB2 support... no
checking for DB1 support... no
checking for DBM support... no
checking for CDB support... no
checking for INI File support... no
checking for FlatFile support... no
checking whether to enable DBA interface... no
checking whether to enable DOM support... yes
checking for xml2-config path... (cached) /usr/local/bin/xml2-config
checking whether libxml build works... (cached) yes
checking for ENCHANT support... no
checking whether to enable EXIF (metadata from images) support... yes
checking for fileinfo support... yes
checking for strcasestr... yes
checking for utimes... yes
checking for strndup... yes
checking whether to enable input filter support... yes
checking pcre install prefix... no
checking whether to enable FTP support... yes
checking OpenSSL dir for FTP... no
checking for GD support... yes
checking for the location of libwebp... /usr/local/lib
checking for the location of libjpeg... /usr/local/lib
checking for the location of libpng... /usr/local/lib
checking for the location of libXpm... no
checking for FreeType 2... /usr/local/lib
checking whether to enable JIS-mapped Japanese font support in GD... no
configure: error: webp/decode.h not found.

*** There was an error while trying to configure php. Check the configure file
Thank you.
 

Dustin_Van

New member
Joined
Dec 4, 2019
Messages
3
Hm.. Does "./build libwebp" succeed?
It does not.


Code:
# ./build libwebp
ERROR: version of php74 not found in versions.txt!
ERROR: version of s-nail not found in versions.txt!
ERROR: version of libwebp not found in versions.txt!
ERROR: version of imagick not found in versions.txt!
ERROR: version of imagemagick not found in versions.txt!
Downloading             libwebp-0.tar.gz...
--2019-12-04 18:27:46--  https://files9.directadmin.com/services/custombuild/libwebp/libwebp-0.tar.gz
Resolving files9.directadmin.com (files9.directadmin.com)... 69.162.69.58
Connecting to files9.directadmin.com (files9.directadmin.com)|69.162.69.58|:443... connected.
HTTP request sent, awaiting response... 404 Not Found
2019-12-04 18:27:46 ERROR 404: Not Found.

Downloaded file /usr/local/directadmin/custombuild/libwebp-0.tar.gz does not exist or is empty after download
cwd is: /usr/local/directadmin/custombuild
Fileserver might be down, using the backup file server..
--2019-12-04 18:27:46--  http://69.162.69.58/services/custombuild/libwebp/libwebp-0.tar.gz
Connecting to 69.162.69.58:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2019-12-04 18:27:46 ERROR 404: Not Found.


gzip: stdin: unexpected end of file
tar: Child returned status 1
tar: Error is not recoverable: exiting now
./build: line 17018: cd: libwebp-0: No such file or directory
./build: line 17020: ./configure: Is a directory
Trying to make libwebp
make: *** No targets specified and no makefile found.  Stop.
 

Dustin_Van

New member
Joined
Dec 4, 2019
Messages
3
Hm.. Does "./build libwebp" succeed?
From the log above, I was able to figure out that somehow it was not getting the version info for the libwebp, so I ran ./build update then ./build libwebp worked fine. Thanks for the help.
 
Top