Issues updating DA

Flaviu ck

New member
Joined
Oct 13, 2013
Messages
5
Hello,
Hello, I updated the DA with the following commands:

cd /usr/local/directadmin/custombuild
./build set php5_ver 5.4
./build update
./build php n

and

cd /usr/local/directadmin/custombuild
./build set mysql 5.1
./build set mysql_inst yes
./build set mysql_backup yes
./build update
./build mysql

and

./build clean
./build versions
./build update_versions

and returning to DA panel conectrame I have these problems

Captura de pantalla 2013-10-14 a la(s) 00.03.25.png
Captura de pantalla 2013-10-14 a la(s) 00.03.34.png


I would greatly appreciate help me fix this
 

streamservice

Verified User
Joined
Dec 14, 2005
Messages
174
Location
The Netherlands
Can you check that you are testing it with:
- Enhanced theme
- English language
- All plugins disabled (rename the plugins directory in /usr/local/directadmin/ if it exists is an option)

You might also want to try another DirectAdmin update.

Edit:
If possible also provide information regarding your operating system and 32bit/64bit and other things around the system that might be important.
 

Flaviu ck

New member
Joined
Oct 13, 2013
Messages
5
Thank you for your speed in answering the Capri skin I've solved, I can only the enhanced.
Is there a single package reinstallation of the skin? Capri type?
 

ditto

Verified User
Joined
Apr 27, 2009
Messages
2,461
It's not related to your question, but I want to remind you that you should always recompile PHP after you upgrade MySQL, but according to your post, you recompiled PHP first, and then MySQL. So you should now do ./build php n one more time. :)
 

Flaviu ck

New member
Joined
Oct 13, 2013
Messages
5
already solved the skin also enhanced,
but I found that the module will not start ionCube.
ERROR:

PHP Deprecated: Comments starting with '#' are deprecated in /usr/local/lib/php.ini on line 491 in Unknown on line 0
Cannot load the ionCube PHP Loader - it was built with configuration 2.2.0, whereas running engine is API220100525,NTS
PHP Warning: PHP Startup: imagick: Unable to initialize module
Module compiled with module API=20060613
PHP compiled with module API=20100525
These options need to match
in Unknown on line 0
PHP Deprecated: Comments starting with '#' are deprecated in /usr/local/lib/php.ini on line 491 in Unknown on line 0
Cannot load the ionCube PHP Loader - it was built with configuration 2.2.0, whereas running engine is API220100525,NTS
PHP Warning: PHP Startup: imagick: Unable to initialize module
Module compiled with module API=20060613
PHP compiled with module API=20100525
These options need to match
in Unknown on line 0

and I have no idea where to look.
thanks again for your help
 

ditto

Verified User
Joined
Apr 27, 2009
Messages
2,461
Regarding imagick, you need to recompile ImageMagick and imagick or remove extension=imagick.so from php.ini

Regarding Ioncube loaders, you need to reinstall those:

Code:
cd /usr/local/directadmin/custombuild
./build update
./build ioncube
Edit: I don't know what you previous php version was, but if you was upgrading from a previous major php version, then I would recommend that you start with a new php.ini file. Take backup of you current php.ini file, then run: ./build php-ini

After that, you recompile ImageMagick and imagick, and do ./build ioncube
 
Last edited:
Top