JM Stacy Freebsd Kernal Errors

goodgirl

Verified User
Joined
Apr 27, 2005
Messages
61
Location
Wheatfield
Jeff said you might be able to help.

I have a server that httpd is down on.

Errors I'm getting:
Jun 27 00:04:03 knucklehead /kernel: kern.maxfiles limit exceeded by uid 0, please see tuning(7).
Jun 27 00:04:13 knucklehead /kernel: kern.maxfiles limit exceeded by uid 0, please see tuning(7).
Jun 27 00:05:00 knucklehead /kernel: kern.maxfiles limit exceeded by uid 12, please see tuning(7).
Jun 27 00:05:03 knucklehead /kernel: kern.maxfiles limit exceeded by uid 0, please see tuning(7).
Jun 27 00:05:15 knucklehead /kernel: kern.maxfiles limit exceeded by uid 0, please see tuning(7).
Jun 27 00:06:03 knucklehead /kernel: kern.maxfiles limit exceeded by uid 0, please see tuning(7).
Jun 27 00:06:09 knucklehead /kernel: arplookup 8.15.0.1 failed: host is not on local network
Jun 27 00:06:13 knucklehead /kernel: kern.maxfiles limit exceeded by uid 0, please see tuning(7).
Jun 27 00:07:03 knucklehead /kernel: kern.maxfiles limit exceeded by uid 0, please see tuning(7).
Jun 27 00:07:04 knucklehead /kernel: arplookup 8.15.0.1 failed: host is not on local network
Jun 27 00:07:11 knucklehead /kernel: arplookup 8.15.0.1 failed: host is not on local network
Jun 27 00:07:13 knucklehead /kernel: kern.maxfiles limit exceeded by uid 0, please see tuning(7).
Jun 27 00:08:02 knucklehead /kernel: kern.maxfiles limit exceeded by uid 0, please see tuning(7).
Jun 27 00:09:03 knucklehead last message repeated 2 times
Jun 27 00:09:08 knucklehead /kernel: arplookup 8.15.0.1 failed: host is not on local network
Jun 27 00:09:08 knucklehead last message repeated 11 times
Jun 27 00:09:13 knucklehead /kernel: kern.maxfiles limit exceeded by uid 0, please see tuning(7).
Jun 27 00:10:03 knucklehead /kernel: kern.maxfiles limit exceeded by uid 0, please see tuning(7).
Jun 27 00:11:13 knucklehead last message repeated 3 times
Jun 27 00:11:56 knucklehead proftpd[18725]: virgil.gotwebhost.com - ProFTPD 1.2.9 (stable) (built Mon Nov 10 00:41:47 MST 2003) standalone mode STARTUP
Jun 27 00:12:03 knucklehead /kernel: kern.maxfiles limit exceeded by uid 0, please see tuning(7).
Jun 27 00:12:13 knucklehead /kernel: kern.maxfiles limit exceeded by uid 0, please see tuning(7).
Jun 27 00:12:30 knucklehead /kernel: arplookup 8.15.0.1 failed: host is not on local network
Jun 27 00:12:58 knucklehead last message repeated 7 times
Jun 27 00:13:02 knucklehead /kernel: kern.maxfiles limit exceeded by uid 0, please see tuning(7).
Jun 27 00:13:12 knucklehead /kernel: kern.maxfiles limit exceeded by uid 0, please see tuning(7).
Jun 27 00:15:13 knucklehead last message repeated 4 times
Jun 27 00:21:13 knucklehead last message repeated 12 times
Jun 27 00:21:23 knucklehead /kernel: arplookup 8.15.0.1 failed: host is not on local network
Jun 27 00:21:37 knucklehead /kernel: arplookup 8.15.0.1 failed: host is not on local network
Jun 27 00:22:02 knucklehead /kernel: kern.maxfiles limit exceeded by uid 0, please see tuning(7).
Jun 27 00:22:12 knucklehead /kernel: kern.maxfiles limit exceeded by uid 0, please see tuning(7).
Jun 27 00:22:28 knucklehead /kernel: arplookup 8.15.0.1 failed: host is not on local network
Jun 27 00:22:54 knucklehead /kernel: arplookup 8.15.0.1 failed: host is not on local network
Jun 27 00:23:03 knucklehead /kernel: kern.maxfiles limit exceeded by uid 0, please see tuning(7).
Jun 27 00:23:13 knucklehead /kernel: kern.maxfiles limit exceeded by uid 0, please see tuning(7).
Jun 27 00:23:26 knucklehead /kernel: arplookup 8.15.0.1 failed: host is not on local network
Jun 27 00:24:03 knucklehead /kernel: kern.maxfiles limit exceeded by uid 0, please see tuning(7).
Jun 27 00:24:13 knucklehead /kernel: kern.maxfiles limit exceeded by uid 0, please see tuning(7).
Jun 27 00:25:13 knucklehead last message repeated 2 times
Jun 27 00:25:43 knucklehead /kernel: arplookup 8.15.0.1 failed: host is not on local network
Jun 27 00:26:03 knucklehead /kernel: kern.maxfiles limit exceeded by uid 0, please see tuning(7).
Jun 27 00:26:13 knucklehead /kernel: kern.maxfiles limit exceeded by uid 0, please see tuning(7).
Jun 27 00:26:35 knucklehead /kernel: arplookup 8.15.0.1 failed: host is not on local network
Jun 27 00:27:02 knucklehead last message repeated 3 times
Jun 27 00:27:02 knucklehead /kernel: kern.maxfiles limit exceeded by uid 0, please see tuning(7).
Jun 27 00:27:12 knucklehead /kernel: kern.maxfiles limit exceeded by uid 0, please see tuning(7).
Jun 27 00:29:13 knucklehead last message repeated 4 times
Jun 27 00:29:30 knucklehead /kernel: arplookup 8.15.0.1 failed: host is not on local network
Jun 27 00:30:03 knucklehead /kernel: kern.maxfiles limit exceeded by uid 0, please see tuning(7).

We did a panel upgrade last night. Today we noticed kernal errors, someone tried to fix that and then httpd went down and now we have these errors. Those are in the System Logs.

httpd error logs show this:
fopen: Too many open files in system
httpd: could not open error log file /var/log/httpd/domains/monikorinok.com.flag.error.log.
fopen: Too many open files in system
httpd: could not open error log file /var/log/httpd/domains/monikorinok.com.flung.error.log.

Any suggestions?
 

Chrysalis

Verified User
Joined
Aug 25, 2004
Messages
1,584
Location
uk
shell command

sysctl kern.maxfiles=65535

and add that line to /etc/sysctl.conf so it applies every reboot.
 

goodgirl

Verified User
Joined
Apr 27, 2005
Messages
61
Location
Wheatfield
Chrysalis said:
shell command

sysctl kern.maxfiles=65535

and add that line to /etc/sysctl.conf so it applies every reboot.
I tried to add that to the systctl.conf and it said permissions denied.
 

goodgirl

Verified User
Joined
Apr 27, 2005
Messages
61
Location
Wheatfield
jlasman said:
So did it work?

Did I guess right?

:)

Jeff
No, it turned out to be an issue caused by too many processes being called with the default of 4,000. Bumped it up to 25k and it seemed to take care of it
 

nobaloney

NoBaloney Internet Svcs - In Memoriam †
Joined
Jun 16, 2003
Messages
26,119
Location
California
Interesting...

issue was processes but error message said maxfiles.

Let's keep that one in mind for the future.

We learn something every day :) .

Jeff
 

BigWil

Verified User
Joined
Aug 5, 2004
Messages
313
Hey JM and Crys! I am locking down some things today and notice that the MIB setting of:

net.inet.tcp.blackhole=2

.... kills imapd. Squirrel and Webmail are both getting timeouts. If I set it to 0 it starts working again. Any ideas? Got to be something about localhost but all other services that talk to localhost are still working fine.

Why this thread.... cause you two are the gurus in here. ;-)

Big Wil
 

Chrysalis

Verified User
Joined
Aug 25, 2004
Messages
1,584
Location
uk
that setting affects what happens when connecting to closed ports, so it shouldnt be affecting your imapd and webmail, I use the setting with no problems.
 

BigWil

Verified User
Joined
Aug 5, 2004
Messages
313
It is the only thing that could be though. Here is my results:

sysctl net.inet.tcp.blackhole=1
net.inet.tcp.blackhole: 0 -> 1

In browser:
Error connecting to IMAP server: localhost.
60 : Operation timed out

sysctl net.inet.tcp.blackhole=2
net.inet.tcp.blackhole: 1 -> 2

In browser:
Error connecting to IMAP server: localhost.
60 : Operation timed out

sysctl net.inet.tcp.blackhole=0
net.inet.tcp.blackhole: 2 -> 0

Everything works fine... Squirrelmail and Webmail.

sysctl net.inet.tcp.blackhole=1
net.inet.tcp.blackhole: 0 -> 1

Error connecting to IMAP server: localhost.
60 : Operation timed out


Could it be conflicting with the ipfilter settings? Those are pretty simple:

vi /etc/sysctl.conf
net.inet.ip.forwarding=1
net.inet6.ip6.forwarding=0
net.inet.ip.fw.verbose=1
net.inet.ip6.fw.verbose=0
#net.inet.tcp.blackhole=2 commented for testing
#net.inet.udp.blackhole=1 commented for testing
net.inet.tcp.log_in_vain=0
net.inet.udp.log_in_vain=0

vi /etc/rc.conf
ipfilter_enable="YES"
ipfilter_rules="/etc/ipf.rules"
ipmon_enable="YES"
ipmon_flags="-Ds"


Big Wil
 
Last edited:

Chrysalis

Verified User
Joined
Aug 25, 2004
Messages
1,584
Location
uk
do you allow localhost all traffic in ipfilter? I use ipfw instead of ipfilter so this could be a problem when using ipfilter.
 
Top