LetsEncrypt update to 1.0.5 is available

ikkeben

Verified User
Joined
May 22, 2014
Messages
714
Location
Netherlands Germany
LetsEncrypt update to 1.0.5 is available

I think this is (almost) required software for most Directadmin Servers. ;)

So i post it here don't know the changes, does someone do?

LetsEncrypt update to 1.0.5 is available
 

dave097

Verified User
Joined
May 8, 2014
Messages
113
Hello ikkeben,

Old situation (version 1.0.4):

chown diradmin:diradmin ${KEY} ${CERT} ${CERT}.combined ${CACERT} ${CSR} ${CERT}.creation_time
chmod 600 ${KEY} ${CERT} ${CACERT} ${CERT}.combined ${CSR} ${CERT}.creation_time

New situation (version 1.0.5):

ACCESS_GROUP_OPTION=`/usr/local/directadmin/directadmin c | grep '^secure_access_group=' | cut -d= -f2`
FILE_CHOWN="diradmin:diradmin"
FILE_CHMOD="640"
if [ "${ACCESS_GROUP_OPTION}" != "" ]; then
FILE_CHOWN="diradmin:${ACCESS_GROUP_OPTION}"
fi

chown ${FILE_CHOWN} ${KEY} ${CERT} ${CERT}.combined ${CACERT} ${CSR} ${CERT}.creation_time
chmod ${FILE_CHMOD} ${KEY} ${CERT} ${CERT}.combined ${CACERT} ${CSR} ${CERT}.creation_time
 
Last edited:

ikkeben

Verified User
Joined
May 22, 2014
Messages
714
Location
Netherlands Germany
Thanks for the replys...

After this update but maybe nothing to do with this update a autorenew gives a error

Getting challenge for thatdomain.eu from acme-server...
Waiting for domain verification...
Challenge is valid.
Getting challenge for www.[U]thatdomain[/U].eu from acme-server...
Challenge error: HTTP/1.1 100 Continue
Expires: Wed, 25 Jan 2017 23:35:27 GMT
Cache-Control: max-age=0, no-cache, no-store
Pragma: no-cache


HTTP/1.1 500 Internal Server Error
Server: AkamaiGHost
Mime-Version: 1.0
Content-Type: text/html
Content-Length: 175
Expires: Wed, 25 Jan 2017 23:35:27 GMT
Cache-Control: max-age=0, no-cache, no-store
Pragma: no-cache
Date: Wed, 25 Jan 2017 23:35:27 GMT
Connection: close
After that error i did this domain manual in DA panel then this was ok without a error.
Getting challenge for thatdomain.eu from acme-server...
Waiting for domain verification...
Challenge is valid.
Getting challenge for www.[U]thatdomain[/U].eu from acme-server...
Waiting for domain verification...
Challenge is valid.
Generating 4096 bit RSA key for thatdomain.eu...
openssl genrsa 4096 > "/usr/local/directadmin/data/users/thatuser/domains/thatdomain.eu.key.new"
Generating RSA private key, 4096 bit long modulus
So only a short hickup or?

the www is redirected to non www in htaccess and normally this is ok , manual in DA panel new letsencrypt for this domain is still ok, autorenew not for the www.
 
Last edited:

tnuz

Verified User
Joined
Jan 12, 2006
Messages
19
Location
Canada
While installing the update I got this error:
Code:
*** MD5 Checksum for all/letsencrypt.sh failed *again*.***
The md5 checksum value may be incorrect, or a wrong file is being downloaded.
Install continuing with this possibly corrupted file. (it may also be fine)
It's probably fine, but doesn't look encouraging.
 

Erulezz

Verified User
Joined
Sep 14, 2015
Messages
438
Location
Arnhem, NL
I think something is wrong with the latest update (1.0.6)?

2017-01-31 20:13:23 (21.9 MB/s) - '/usr/local/directadmin/custombuild/letsencrypt.sh' saved [21604/21604]

Let's encrypt client 1.0.6 has been installed.
[root@web01 custombuild]# ./build versions
Latest version of DirectAdmin: 1.50.1
Installed version of DirectAdmin: 1.50.1

Latest version of Let's Encrypt client: 1.0.6
Installed version of Let's Encrypt client: 1.0.5

Let's Encrypt client 1.0.5 to 1.0.6 update is available.
:confused:
 

nielsh

Verified User
Joined
May 15, 2015
Messages
46
I think something is wrong with the latest update (1.0.6)?



:confused:
I've been having the same issues, it seems that files1 has 1.0.6 but mirrors have 1.0.5. It'd be good if the versions file came from the same mirror to prevent this, but it's probably a matter of waiting for the mirrors now...
 

andreiut

Verified User
Joined
Apr 7, 2014
Messages
11
Latest version of Let's Encrypt client: 1.0.4
Installed version of Let's Encrypt client: 1.0.4

hmm.. i can't see the latest 1.0.5 version.
 

SeLLeRoNe

Super Moderator
Joined
Oct 9, 2004
Messages
6,793
Location
A Coruña, Spain
Latest version is 1.0.6, probably the mirror you're using is not updated.

Try to run this:
Code:
/usr/local/directadmin/custombuild/build set_fastest
/usr/local/directadmin/custombuild/build update
/usr/local/directadmin/custombuild/build versions
Best regards
 

andreiut

Verified User
Joined
Apr 7, 2014
Messages
11
Latest version is 1.0.6, probably the mirror you're using is not updated.

Try to run this:
Code:
/usr/local/directadmin/custombuild/build set_fastest
/usr/local/directadmin/custombuild/build update
/usr/local/directadmin/custombuild/build versions
Best regards
it worked, thank you. :)
 
Top