Location / LocationMatch not working

Nickske00

Verified User
Joined
Nov 30, 2015
Messages
69
Hi,

I have some trouble with a little custom httpd directives. I recently installed a new server and moved my data to it, since then my configuration stopped working.

So I have this under Custom HTTPD configuration:
Code:
|*if SSL_TEMPLATE="1"|
SSLCACertificatePath /home/client03/domains/projectjeugd.be/certificates/
SSLUseStapling off
|*endif|

And in CUSTOM4 I have:
Code:
|*if SSL_TEMPLATE="1"|
<LocationMatch "/register/eid">
  SSLOptions +StdEnvVars +ExportCertData
  SSLVerifyClient require
  SSLVerifyDepth 2
</LocationMatch>
|*endif|

And the whole virtual host ends up being:
Code:
<VirtualHost 185.87.186.100:443 [2a00:f10:121:b00:444:faff:fe00:1c81]:443 >
SSLCACertificatePath /home/client03/domains/projectjeugd.be/certificates/
SSLUseStapling off
	SSLEngine on
	SSLCertificateFile /usr/local/directadmin/data/users/client03/domains/projectjeugd.be.cert
	SSLCertificateKeyFile /usr/local/directadmin/data/users/client03/domains/projectjeugd.be.key
	SSLCACertificateFile /usr/local/directadmin/data/users/client03/domains/projectjeugd.be.cacert
	ServerName www.projectjeugd.be
	ServerAlias www.projectjeugd.be projectjeugd.be 
	ServerAdmin [email protected]
	DocumentRoot /home/client03/domains/projectjeugd.be/private_html
	UseCanonicalName OFF
	<IfModule !mod_ruid2.c>
		SuexecUserGroup client03 client03
	</IfModule>
	<IfModule mod_ruid2.c>
		RMode config
		RUidGid client03 client03
		#RGroups apache access
		RGroups @none
	</IfModule>
	CustomLog /var/log/httpd/domains/projectjeugd.be.bytes bytes
	CustomLog /var/log/httpd/domains/projectjeugd.be.log combined
	ErrorLog /var/log/httpd/domains/projectjeugd.be.error.log
	<Directory /home/client03/domains/projectjeugd.be/private_html>
		AllowOverride AuthConfig FileInfo Indexes Limit Options=Indexes,IncludesNOEXEC,MultiViews,SymLinksIfOwnerMatch,FollowSymLinks,None
		Options -ExecCGI -Includes +IncludesNOEXEC
		<FilesMatch "\.(inc|php|phtml|phps|php56)$">
			AddHandler "proxy:unix:/usr/local/php56/sockets/client03.sock|fcgi://localhost" .inc .php .phtml .php56
		</FilesMatch> 
	</Directory>
<LocationMatch "/register/eid">
  SSLOptions +StdEnvVars +ExportCertData
  SSLVerifyClient require
  SSLVerifyDepth 2
</LocationMatch>
</VirtualHost>

But for some reason he isn't catching my url... When I visit https://projectjeugd.be/register/eid it's not working. On the other server it worked fine. So am I missing something? Can a LocationMatch be disabled?

When I move the 'SSLOptions +StdEnvVars +ExportCertData' setting to the top field, I get the extra SSL server variables everywhere on the website, so I know the custom configuration takes effect. It's only not catching the url... Any ideas?
 

Nickske00

Verified User
Joined
Nov 30, 2015
Messages
69
I solved it by disabling mod_ruid2 and rebuilding apache and rewriting the config files. So it appears mod_ruid2 was tampering with the url somehow...
 
Top