Mod_securit

cabn12

Verified User
Joined
Dec 17, 2019
Messages
20
Good night everyone, I installed the mod_sec and the owasp rules, everything went very well, but when accessing the webmail from error 500, that is, it does not load the webmail roundcube, but if you uninstall mod_sec and its rules everything will be fine.
Would it be better to use mod_sec plus the rules of comodo because it did not give error?
 

cabn12

Verified User
Joined
Dec 17, 2019
Messages
20
I'm loving directadmin, a light and very cool panel, just one more question? I installed cloudlinux and the php selector with its old and current versions of php, I did the following in DA:
# cd / usr / local / directadmin / custombuild

# ./build set php1_release 7.2 # select the default DA version
# ./build set php2_release no # set the rest to no
# ./build set php3_release no
# ./build set php4_release no

# ./build php n
# ./build rewrite_confs

# cagefsctl --force-update
# cagefsctl --remount-all
# cagefsctl --setup-cl-selector
When checking the php selector it works but I lost the configuration of the ionCube PHP Loader this is only selected in the php selector and I have an application that does not run because I get the message below:
ite error: the ionCube PHP Loader needs to be installed. This is a widely used PHP extension for running ionCube protected PHP code, website security and malware blocking. Please visit get-loader.ioncube.com for install assistance.
Obs. The default domain of DA is not in the cage of cloudlinux this I cannot add.
 

zEitEr

Super Moderator
Joined
Apr 11, 2005
Messages
14,146
Location
GMT +7.00
If you use a PHP version from CloudLinux (vs native), then you need to install alt-php package of ionCube. Just check with yum for the correct name.
 

cabn12

Verified User
Joined
Dec 17, 2019
Messages
20
is the cpguard plugin it is installed as a plugin until I left the native versions of DA 7.3, 7.2, 7.1 AND 7.0 WORKING PERFECTLY after I ran the command above for the php selector the plugin reports the error above.
 

cabn12

Verified User
Joined
Dec 17, 2019
Messages
20
./build ioncube
Downloading ioncube_loaders_lin_x86-64.tar.gz...
--2020-02-12 06:44:03-- https://files9.directadmin.com/services/custombuild/ion cube_10.3.9/ioncube_loaders_lin_x86-64.tar.gz
Resolving files9.directadmin.com (files9.directadmin.com)... 69.162.69.58
Connecting to files9.directadmin.com (files9.directadmin.com)|69.162.69.58|:443. .. connected.
HTTP request sent, awaiting response... 200 OK
Length: 12619060 (12M) [application/x-gzip]
Saving to: '/usr/local/directadmin/custombuild/ioncube_loaders_lin_x86-64.tar.gz '

100%[======================================>] 12,619,060 7.94MB/s in 1.5s

2020-02-12 06:44:05 (7.94 MB/s) - '/usr/local/directadmin/custombuild/ioncube_lo aders_lin_x86-64.tar.gz' saved [12619060/12619060]

ionCube loader 10.3.9 is now installed for PHP 7.2.
CageFS: Executing 'cagefsctl --force-update'...
Copying /usr/local/php72/lib/php.conf.d/10-directadmin.ini to /usr/share/cagefs- skeleton/usr/local/php72/lib/php.conf.d/10-directadmin.ini
Copying /usr/local/php72/var/log/php-fpm.log to /usr/share/cagefs-skeleton/usr/l ocal/php72/var/log/php-fpm.log
Copying /bin/su to /usr/share/cagefs-skeleton/usr/bin/su
Updating users ...
Updating user paroquiasaojudas ...
Updating user wwwjucelino ...
Removed file /var/cagefs/11/wwwjucelino/etc/alternatives/libnssckbi.so.x86_64
Removed file /var/cagefs/11/wwwjucelino/etc/pam.d/fingerprint-auth-ac
Removed file /var/cagefs/11/wwwjucelino/etc/pam.d/password-auth-ac
Removed file /var/cagefs/11/wwwjucelino/etc/pam.d/postlogin-ac
Removed file /var/cagefs/11/wwwjucelino/etc/pam.d/smartcard-auth-ac
Removed file /var/cagefs/11/wwwjucelino/etc/pam.d/system-auth-ac
Updating user jubr12a ...
Updating user jucejpblog ...
Removed file /var/cagefs/12/jucejpblog/etc/alternatives/libnssckbi.so.x86_64
Removed file /var/cagefs/12/jucejpblog/etc/pam.d/fingerprint-auth-ac


Error persist Site error: the ionCube PHP Loader needs to be installed. This is a widely used PHP extension for running ionCube protected PHP code, website security and malware blocking. Please visit get-loader.ioncube.com for install assistance.
 
Top