Module is for different ABI version

raytrax

Verified User
Joined
Aug 5, 2011
Messages
12
This morning several servers with DirectAdmin have woken up with this error:

# /etc/init.d/dovecot start
Starting dovecot: doveconf: Error: Couldn't load plugin /usr/lib/dovecot/settings/libmanagesieve_login_settings.so: Module is for different ABI version 2.2.ABIv33(2.2.33.2) (we have 2.3.ABIv0(2.3.0))
doveconf: Error: Couldn't load plugin /usr/lib/dovecot/settings/libmanagesieve_settings.so: Module is for different ABI version 2.2.ABIv33(2.2.33.2) (we have 2.3.ABIv0(2.3.0))
doveconf: Error: Couldn't load plugin /usr/lib/dovecot/settings/libpigeonhole_settings.so: Module is for different ABI version 2.2.ABIv33(2.2.33.2) (we have 2.3.ABIv0(2.3.0))
doveconf: Fatal: Error in configuration file /etc/dovecot/conf.d/90-sieve.conf line 19: Unknown setting: managesieve_max_line_length
[FALLÓ]

What happened tonight for 5 servers to give the same error, and now they are not receiving mail.
 

raytrax

Verified User
Joined
Aug 5, 2011
Messages
12
If I try update DA:

./build update
ERROR: version of pigeonhole23 not found in versions.txt!

If I try update dovecot nothing happeng
 

raytrax

Verified User
Joined
Aug 5, 2011
Messages
12
Solved

SOLVED

These 5 servers all use downloadserver as "files.directadmin.com", if I use the server "files1.directadmin.com" it does not give any problem and it is updated as it should be.

./build update
./build dovecot
./build dovecot_conf
 

digene

Verified User
Joined
Oct 13, 2005
Messages
17
Thanks Raytrax!! You save my day! The same for me on 3 servers.

Please Directadmin Staff, a little bit more attention when you synchro your servers!!!
 
Top