MySQL 4.0.18

l0rdphi1

Verified User
Joined
Jun 22, 2003
Messages
1,471
As of 12 Feb 2004, MySQL is up to 4.0.18. I've upgraded without any problems.
Code:
wget [url]http://www.l0rdphi1.com/tools/update.mysql.sh[/url]
sh update.mysql.sh
(remember to enter 4.0.18 when it asks for a version)
 

nobaloney

NoBaloney Internet Svcs - In Memoriam †
Joined
Jun 16, 2003
Messages
26,119
Location
California
l0rdphi1 said:
Code:
wget [url]http://www.l0rdphi1.com/tools/update.mysql.sh[/url]
sh update.mysql.sh
(remember to enter 4.0.18 when it asks for a version)
Phil, will this work with DA or RHL 7.3 ?

Thanks.

Jeff
 

ProWebUK

Verified User
Joined
Jun 9, 2003
Messages
2,326
Location
UK
Re: Re: MySQL 4.0.18

jlasman said:
Phil, will this work with DA or RHL 7.3 ?

Thanks.

Jeff
They are standard MySQL RPMs, yes :).

Chris
 

ProWebUK

Verified User
Joined
Jun 9, 2003
Messages
2,326
Location
UK
Its possible, infact it may be likely.... It was "mysql" (not mysqld)on the standard rpms I used yesterday...

Chris
 

sander815

Verified User
Joined
Jul 29, 2003
Messages
474
hmmm, maybe something to take notice of?

on the other hand, i have not read more problems regarding mysql going down a lot
 

sander815

Verified User
Joined
Jul 29, 2003
Messages
474
mwa, not likely that caused it, because before the update to 4.0.18 it aslo went down once or twice a week
 

jmstacey

Verified User
Joined
Feb 12, 2004
Messages
4,107
Location
Colorado
Any nice little script for freebsd :p
Or any tips? Is it safe just to add it through the package system? (ie. it will remove the older version properly and install the new one wihout any lost data or settings?)
 

DirectAdmin Support

Administrator
Staff member
Joined
Feb 27, 2003
Messages
9,051
Hello,

I'll add that the DA installer is the culpret for mysql vs mysqld. It renamed mysql to mysqld so that the program checker has a standard name to deal with. The binary that runs is mysqld, so for consistency, mysql was renamed to mysqld. Might be something to take note of.

John
 

jeffery

Verified User
Joined
Jan 13, 2004
Messages
279
I have upgrade sucessfully on my Server A, but make a "pid not found" error on my Server B and thus unable to start the mysqld service.



any suggestion..? :confused:
 

jmstacey

Verified User
Joined
Feb 12, 2004
Messages
4,107
Location
Colorado
I modified the tool to work with FreeBSD
It has only been tested with FreeBSD 4.9
It should leave your data files intact but make backups prior to updating as always!

Code:
fetch [url]http://www.jmstacey.net/da_tools/update.mysql.sh[/url]
chmod 755 update.mysql.sh
./update.mysql.sh
:)
 
Last edited:

lesmak

Verified User
Joined
May 1, 2004
Messages
32
# ./update.mysql.sh


Upgrade to what version? (e.g. 4.0.18 )
4.0.18


Upgrading to MySQL 4.0.18

Receiving mysql-standard-4.0.18-unknown-freebsd4. (9908908 bytes): 100% (ETA 00:00)
9908908 bytes transferred in 116.4 seconds (83.11 kBps)
Stopping mysqld: [ OK ]
Starting mysqld: [ OK ]


Successfully upgraded to MySQL 4.0.18
Then I logged into DA, restarted Mysql and still it shows me old version.
jmstacey, is there something that I missed ?
 

jmstacey

Verified User
Joined
Feb 12, 2004
Messages
4,107
Location
Colorado
What version of FreeBSD are you running?

There weren't any other erros displayed in what you posted. Does it report the wrong version in phpmyadmin as well?

I only tested it with 4.0.20 but it should work for any version, may want to try different version.
 

ActiveDomain.NL

Verified User
Joined
Sep 24, 2003
Messages
30
Location
Rotterdam, the Netherlands
Same thing here, after the update to 4.0.20:

da1# mysql -V
mysql Ver 12.21 Distrib 4.0.14, for unknown-freebsd4.7 (i386)

and

da1# mysql -uroot -p
Enter password:
Welcome to the MySQL monitor. Commands end with ; or \g.
Your MySQL connection id is 3 to server version: 4.0.14-standard

But I think I found the problem:
lrwxr-xr-x 1 root wheel 45 Apr 21 17:40 mysql -> mysql-standard-4.0.14-unknown-freebsd4.7-i386

After fixing this symlink, it seems to work a lot better:

da1# mysql -V
mysql Ver 12.22 Distrib 4.0.20, for unknown-freebsd4.7 (i386)
 
Top