MySQL Community Server 5.1.50 has been released

Meesterlijk

Verified User
Joined
Jan 19, 2007
Messages
179
Location
Netherlands
Dear MySQL users,

MySQL Community Server 5.1.50, a new version of the popular Open
Source Database Management System, has been released. MySQL 5.1.50 is
recommended for use on production systems.

For an overview of what's new in MySQL 5.1, please see

http://dev.mysql.com/doc/refman/5.1/en/mysql-nutshell.html

For information on installing MySQL 5.1.50 on new servers or upgrading
to MySQL 5.1.50 from previous MySQL releases, please see

http://dev.mysql.com/doc/refman/5.1/en/installing.html

MySQL Server is available in source and binary form for a number of
platforms from our download pages at

http://dev.mysql.com/downloads/

Not all mirror sites may be up to date at this point in time, so if
you can't find this version on some mirror, please try again later or
choose another download site.

We welcome and appreciate your feedback, bug reports, bug fixes,
patches, etc.:

http://forge.mysql.com/wiki/Contributing

For information on open issues in MySQL 5.1, please see the errata
list at

http://dev.mysql.com/doc/refman/5.1/en/open-bugs.html

The following section lists the changes in the MySQL source code since
the previous released version of MySQL 5.1. It may also be viewed
online at

http://dev.mysql.com/doc/refman/5.1/en/news-5-1-50.html

Enjoy!

=======================================================================

C.1.1. Changes in MySQL 5.1.50 (03 August 2010)

InnoDB Notes:

* InnoDB Plugin has been upgraded to version 1.0.11. This
version is considered of General Availability (GA) quality.
In this release, the InnoDB Plugin is included in source and
binary distributions, except RHEL3, RHEL4, SuSE 9 (x86,
x86_64, ia64), generic Linux RPM packages, and any builds
produced with the icc compiler. It also does not work for
FreeBSD 6 and HP-UX or for Linux on generic ia64.

Bugs fixed:

* Important Change: Replication: The LOAD DATA INFILE statement
is now considered unsafe for statement-based replication. When
using statement-based logging mode, the statement now produces
a warning; when using mixed-format logging, the statement is
made using the row-based format.
(Bug#34283: http://bugs.mysql.com/bug.php?id=34283)

* Partitioning: UPDATE and INSERT statements affecting
partitioned tables performed poorly when using row-based
replication.
(Bug#52517: http://bugs.mysql.com/bug.php?id=52517)

* Partitioning: INSERT ON DUPLICATE KEY UPDATE statements
performed poorly on tables having many partitions. This was
because the handler function for reading a row from a specific
index was not optimized in the partitioning handler.
(Bug#52455: http://bugs.mysql.com/bug.php?id=52455)

* The server could crash on shutdown, if started with
--innodb-use-system-malloc=0.
(Bug#55581: http://bugs.mysql.com/bug.php?id=55581)

* GROUP BY operations used max_sort_length inconsistently.
(Bug#55188: http://bugs.mysql.com/bug.php?id=55188)

* Building MySQL on Solaris 8 x86 failed when using Sun Studio
due to gcc inline assembler code.
(Bug#55061: http://bugs.mysql.com/bug.php?id=55061)

* In debug builds, an assertion could be raised when the server
tried to send an OK packet to the client after having failed
to detect errors during processing of the WHERE condition of
an UPDATE statement.
(Bug#54734: http://bugs.mysql.com/bug.php?id=54734)

* The database server could crash when renaming a table that had
active transactions. (This issue only affected the database
server when built for debugging.)
(Bug#54453: http://bugs.mysql.com/bug.php?id=54453)

* The server could crash during the recovery phase of startup,
if it previously crashed while inserting BLOB or other large
columns that use off-page storage into an InnoDB table created
with ROW_FORMAT=REDUNDANT or ROW_FORMAT=COMPACT.
(Bug#54408: http://bugs.mysql.com/bug.php?id=54408)

* For an InnoDB table created with ROW_FORMAT=COMPRESSED or
ROW_FORMAT=DYNAMIC, a query using the READ UNCOMMITTED
isolation level could cause the server to stop with an
assertion error, if BLOB or other large columns that use
off-page storage were being inserted at the same time.
(Bug#54358: http://bugs.mysql.com/bug.php?id=54358)

* A client could supply data in chunks to a prepared statement
parameter other than of type TEXT or BLOB using the
mysql_stmt_send_long_data() C API function (or
COM_STMT_SEND_LONG_DATA command). This led to a crash because
other data types are not valid for long data.
(Bug#54041: http://bugs.mysql.com/bug.php?id=54041)

* mysql_secure_installation did not properly identify local
accounts and could incorrectly remove nonlocal root accounts.
(Bug#54004: http://bugs.mysql.com/bug.php?id=54004)

* Transactions could be incorrectly committed during recovery,
rather than rolled back, if the server crashed and was
restarted after performing ALTER TABLE...ADD PRIMARY KEY on an
InnoDB table, or some other operation that involves copying
the entire table.
(Bug#53756: http://bugs.mysql.com/bug.php?id=53756)

* Portability problems in SHOW STATUS could lead to incorrect
results on some platforms.
(Bug#53493: http://bugs.mysql.com/bug.php?id=53493)

* Builds of MySQL generated a large number of warnings.
(Bug#53445: http://bugs.mysql.com/bug.php?id=53445)

* With lower_case_table_names set to a nonzero value, searches
for table or database names in INFORMATION_SCHEMA tables could
produce incorrect results.
(Bug#53095: http://bugs.mysql.com/bug.php?id=53095)

* The ABI check for MySQL failed to compile with gcc 4.5.
(Bug#52514: http://bugs.mysql.com/bug.php?id=52514)

* mysql_secure_installation sometimes failed to locate the mysql
client. (Bug#52274: http://bugs.mysql.com/bug.php?id=52274)

* Reading a ucs2 data file with LOAD DATA INFILE was subject to
three problems. 1) Incorrect parsing of the file as ucs2 data,
resulting in incorrect length of the parsed string. This is
fixed by truncating the invalid trailing bytes (incomplete
multibyte characters) when reading from the file. 2) Reads
from a proper ucs2 file did not recognize newline characters.
This is fixed by first checking whether a byte is a newline
(or any other special character) before reading it as a part
of a multibyte character. 3) When using user variables to hold
column data, the character set of the user variable was set
incorrectly to the database charset. This is fixed by setting
it to the character set specified in the LOAD DATA INFILE
statement, if any.
(Bug#51876: http://bugs.mysql.com/bug.php?id=51876)

* Searches in INFORMATION_SCHEMA tables for rows matching a
nonexistent database produced an error instead of an empty
query result.
(Bug#49542: http://bugs.mysql.com/bug.php?id=49542)

* On FreeBSD, memory mapping for MERGE tables could fail if
underlying tables were empty.
(Bug#47139: http://bugs.mysql.com/bug.php?id=47139)

* The my_like_range_xxx() functions returned badly formed
maximum strings for Asian character sets, which caused
problems for storage engines.
(Bug#45012: http://bugs.mysql.com/bug.php?id=45012)

* A debugging assertion could be raised after a write failure to
a closed socket.
(Bug#42496: http://bugs.mysql.com/bug.php?id=42496)

* An assertion failure occurred within yaSSL for very long keys.
(Bug#29784: http://bugs.mysql.com/bug.php?id=29784)
See also Bug#53463: http://bugs.mysql.com/bug.php?id=53463.


Thanks,
MySQL RE Team

Karen Langford MySQL Release Engineer
Database Group, Oracle.
 

Elfodellanotte

Verified User
Joined
Apr 12, 2008
Messages
81
Location
Brno (Czech Republic)
are you sure?

yes is true... but after update ... :

Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2)

howto solve? any suggestion?

even if i create the file mysql.sock it will be deleted when i'm trying to start mysql...

EDIT : Solved, the installation wasn't killing properly the pid, and after a kill -9 and /etc/init.d/mysqld start it work again :)
 
Last edited:
Top