need help, messed up updating to apache 2.4.2

dmacleo

Verified User
Joined
Jun 21, 2012
Messages
641
I don't even know where to start now LOL
was on CB 1.1 and tried to update apache, editied the options file and it seemed to go ok even though it took hours.
and now when I get try to restart apache I get virtual directory conflict errors (I forgot to copy them) and all sites goto the apache is working ok page.

I am attempting to update to CD 1.2 and rerunning the 2.4.2 update, anything I should look for?
I may be wrong (as I forgot to grab info) but it looked like mod_ruid was automatically enabled which I never enabled prior.
 

dmacleo

Verified User
Joined
Jun 21, 2012
Messages
641
this is odd

after 20 min of not working it just started working. I am confused.
how do I get set so I donn't have unanswerable questions before I can post?
thanks.
 

SeLLeRoNe

Super Moderator
Joined
Oct 9, 2004
Messages
6,792
Location
A Coruña, Spain
mod_ruid2 is not installed by default.

Just the template are ready for mod_ruid2 doenst mean it is installed.

My suppose is that you have some custom template that somehow did conflict with apache 2.4 but cannot be sure without any investigation.

Regards
 

dmacleo

Verified User
Joined
Jun 21, 2012
Messages
641
ok that may be what I saw on mod_ruid.
have not knowingly installed any custom template, only had thesystem running 2 days.
stopped running on me overnight and I get this trying to start it
Starting httpd: [Mon Jun 25 05:31:31.474304 2012] [core:warn] [pid 21392] AH00117: Ignoring deprecated use of DefaultType in line 60 of /etc/httpd/conf/httpd.co
I removed the default type line and now no errors come up but still lists as being stopped after I do /etc/init.d/httpd start.
just woke up so have not looked deeply yet.
 

SeLLeRoNe

Super Moderator
Joined
Oct 9, 2004
Messages
6,792
Location
A Coruña, Spain
That was a warning, remove the line or ignore it is the same :) But no problem on deleting the line.

Have you checked apache logs?

Regards
 

dmacleo

Verified User
Joined
Jun 21, 2012
Messages
641
just starting to get into that now, am not sure my ./build php n went right last night so am redoing that right now first
 

dmacleo

Verified User
Joined
Jun 21, 2012
Messages
641
basically just this repeated:
[Mon Jun 25 05:52:13.001099 2012] [ssl:notice] [pid 32164] AH01886: SSL FIPS mode disabled
[Mon Jun 25 05:52:13.065652 2012] [ssl:warn] [pid 32164] AH01909: RSA certificate configured for www.example.com:443 does NOT include an ID which matches the server name
[Mon Jun 25 05:52:13.065816 2012] [ssl:warn] [pid 32164] AH01909: RSA certificate configured for shared.domain:443 does NOT include an ID which matches the server name
[Mon Jun 25 05:52:13.065902 2012] [ssl:warn] [pid 32164] AH01909: RSA certificate configured for shared.domain:443 does NOT include an ID which matches the server name
[Mon Jun 25 05:52:13.065918 2012] [ssl:warn] [pid 32164] AH02292: Init: Name-based SSL virtual hosts only work for clients with TLS server name indication support (RFC 4366)
[Mon Jun 25 05:52:13.065929 2012] [suexec:notice] [pid 32164] AH01232: suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Mon Jun 25 05:52:13.091644 2012] [auth_digest:notice] [pid 32165] AH01757: generating secret for digest authentication ...
[Mon Jun 25 05:52:13.091832 2012] [core:emerg] [pid 32165] (28)No space left on device: AH00023: Couldn't create the authdigest-opaque mutex
[Mon Jun 25 05:52:13.091848 2012] [auth_digest:error] [pid 32165] (28)No space left on device: AH01760: failed to create lock (opaque_lock) - all nonce-count checking, one-time nonces, and MD5-sess algorithm disabled
[Mon Jun 25 05:52:13.091885 2012] [:emerg] [pid 32165] AH00020: Configuration Failed, exiting
thought I saw that error mentioned here last night but cannot find it now
 

dmacleo

Verified User
Joined
Jun 21, 2012
Messages
641
should be plenty of space, drives report few hundred gb free.
I did reboot and httpd ran a few then stopped.
think I need to go back to 2.2 and start fresh on trying 2.4, not sure I have enough experience to TS this fast enough.
 

dmacleo

Verified User
Joined
Jun 21, 2012
Messages
641
heres latest

did try rollback to 2.2
[Mon Jun 25 06:23:14 2012] [notice] SSL FIPS mode disabled
[Mon Jun 25 06:23:14 2012] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
[Mon Jun 25 06:23:14 2012] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
[Mon Jun 25 06:23:14 2012] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
[Mon Jun 25 06:23:14 2012] [warn] Init: Name-based SSL virtual hosts only work for clients with TLS server name indication support (RFC 4366)
PHP Warning: Module 'ionCube Loader' already loaded in Unknown on line 0
so think the ioncube may have been issue all along, need to see why though as was working fine prior
 

dmacleo

Verified User
Joined
Jun 21, 2012
Messages
641
I will know more in a bit

but I suspect it may be related to this change in my php ini file

zend_extension=/usr/local/lib/ioncube_loader_lin_5.3.so
zend_extension = /usr/local/ioncube/ioncube_loader_lin_5.3.so
the usr/local/lib location got added somehow during compile
 

ditto

Verified User
Joined
Apr 27, 2009
Messages
2,540
You might have a older ioncube installed (newest is 4.2.1). To make sure you have the newest installed, please go to this path:
/usr/local/directadmin/custombuild

At that path, delete ioncube_loaders_lin_x86-64.tar.gz - also if you have a folder/directory at that path with the name ioncube in it, then delete that directory too.

Also if you have a folder/directory at that path with php in the name, delete that folder/directory too.

Also, if you recently upgraded PHP, also try to delete /usr/local/etc/php5/cgi/php.ini (so that it will be created from default template when you recompile php).

Then after all that, try to recompile:

cd /usr/local/directadmin/custombuild
./build php n

and then:
./build ioncube

and maybe also after that:

./build apache

and

./build suphp (if you have it installed)

Good luck!
 

dmacleo

Verified User
Joined
Jun 21, 2012
Messages
641
I will try that next

thanks,
trying to get it back to running 2.2 and starting fresh as I suspected there were 2.4 build issues last night as it took 3 hours almost.
 

dmacleo

Verified User
Joined
Jun 21, 2012
Messages
641
well apache running now, phpmyadmin has
Fatal error: session_start() [<a href='function.session-start'>function.session-start</a>]: Failed to initialize storage module: files (path: ) in /var/www/html/phpMyAdmin-3.5.1-all-languages/libraries/session.inc.php on line 78
and for some reason, and I have double checked php.ini, its loading safe mode.
going to redo compile again.
 

dmacleo

Verified User
Joined
Jun 21, 2012
Messages
641
LOL I cannot catch a break today.
stuff was running ok on 2.4 last night so going to try that again and make sure to watch for that ioncube loader issue.
hopefully I can at least get stuff running again.
 

dmacleo

Verified User
Joined
Jun 21, 2012
Messages
641
the phpmyadmin error were caused by safe mode.
my php ini has always had
;safe_mode = Off
and worked fine and on apache 2.2.22 reported as OFF in applications.
now it needs to be
safe_mode = Off
namely the ; is not there.
hope that may help someone if the get that phpmyadmin error
 

dmacleo

Verified User
Joined
Jun 21, 2012
Messages
641
the phpmyadmin error were caused by safe mode.
my php ini has always had

and worked fine and on apache 2.2.22 reported as OFF in applications.
now it needs to be

namely the ; is not there.
hope that may help someone if the get that phpmyadmin error
and I am thinking that the ; version worked as safe mode was off as default until update. wondering if removing
[core:warn] [pid 21392] AH00117: Ignoring deprecated use of DefaultType in line 60 of /etc/httpd/conf/httpd.co
then drove it to safe on as the ;safe_mode=off was just a comment and not cmd.

not sure, but seems to be working now.

now I need to monitor all day to make sure I don't get any crashes.
 

dmacleo

Verified User
Joined
Jun 21, 2012
Messages
641
well I am just trying to see why the default of safe mode off (which has been in place for over a year) was suddenly changed to safe mode on just by ugrading.
thought maybe removing DefaultType statement in httpd.conf might have caused it to flip it to on.
I just can't see any reason why safe mode would have flipped.

its working now although I am seeing 2.4.2 seems to be slower than 2.2.22 for my setup.
so all this will probably be moot as I will probably revert back to 2.2.22 LOL
 
Top